Bug 116957 - Openoffice does not show equations correctly
Openoffice does not show equations correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-26 15:15 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 20:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Two page presentation, equations on second page (19.30 KB, application/octet-stream)
2004-02-26 15:16 EST, Sammy
no flags Details
What the equation looks like on Dan's machine (108.51 KB, image/png)
2004-02-27 10:10 EST, Dan Williams
no flags Details

  None (edit)
Description Sammy 2004-02-26 15:15:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en) (KHTML, like Gecko)

Description of problem:
Since the version 1.1.0-10 (after the major repackaging changes) I
cannot make the equation fonts show correctly in openoffice impress.

I am attaching a two page presentation as a test case. First page
which only contains ordinary text shows ok. The second page with
equations are all garbled.

Now, the details. There was a way to add fonts via spadmin to openoffice.
For these to work I had to add a bunch of fonts. I cannot find that
procedure anymore. I know how to do it by hand so I tried adding
the fonts to /usr/share/fonts/openoffice, created the cache file,
modified the psfontcache file to point to this directory and contain 
these fonts. At the end of the day I failed. My point is: What is the
methodology for adding fonts to openoffice now? Is it supposed to get
the system fonts automatically? If yes, which ones? anti-aliased or not?

Thanks

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-28

How reproducible:
Always

Steps to Reproduce:
1.update openoffice from an older version (say -10)
2.try to open a presentation that contains equations
3.
    

Additional info:
Comment 1 Sammy 2004-02-26 15:16:55 EST
Created attachment 98083 [details]
Two page presentation, equations on second page
Comment 2 Dan Williams 2004-02-27 10:09:38 EST
OOo now looks for fonts in the normal Linux font locations, namely
/usr/share/fonts.  Any font that is known by fontconfig will be
available to OOo.  Can you attach a screenshot of what the
presentation _should_ look like?  I've attached what it looks like on
my machine...
Comment 3 Dan Williams 2004-02-27 10:10:05 EST
Created attachment 98101 [details]
What the equation looks like on Dan's machine
Comment 4 Sammy 2004-02-27 11:16:14 EST
Well, your machine shows them exactly the way they should look 
(presume this is a screen image). 
 
When you say fontconfig should now, does that mean they should 
be listed in the /etc/fonts/fonts.conf file? 
 
 
Comment 5 Dan Williams 2004-02-27 11:35:58 EST
Hmm, I'm not sure.  I don't have them listed there, and fontconfig
should find them because I'm running fc-cache on the OOo font
directory after installation of the RPM.  Can you try running
"fc-cache /usr/share/fonts/openoffice" and see what happens?
Comment 6 Sammy 2004-02-27 12:02:52 EST
After the fresh install of the rpms I got the bad view again. I than 
restarted X, same problem. Finally, I added /usr/share/fonts/openoffice 
to the /etc/fonts/fonts.conf and restarted X, IT WORKED! 
 
I did run fc-cache after I installed the rpms and it worked fine. 
 
So, the million dollar question is why is it working on your system 
without the fonts.conf file? Are you using anti-aliasing? I am. 
 
My next question will be the printer definitions. I need to add some 
PPD's, how do we do this now? Will it pick stuff automatically from CUPS? 
Well, I just checked it and it seems to do that. Let me know if I am wrong. 
This is great. I don't have to add stuff after every upgrade. 
 
Comment 7 Sammy 2004-02-27 15:41:05 EST
Another thought is that the openoffice directory may be described 
in XFree86-4 file or via xfs. 
Comment 8 Caolan McNamara 2004-11-05 20:15:05 EST
Yeah, OOo should simply pick up on the PPD's from CUPS. 
Right now with an un-modified 1.1.2-10 and FC-3 without any hacking it
looks right and works out of the box.

Note You need to log in before you can comment on or make changes to this bug.