Bug 116962 - Authoring kit details panel on CT page confusing / not for admin
Authoring kit details panel on CT page confusing / not for admin
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Jon Orris
:
Depends On:
Blocks: 113496
  Show dependency treegraph
 
Reported: 2004-02-26 16:41 EST by Richard Li
Modified: 2007-04-18 13:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 14:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Li 2004-02-26 16:41:43 EST
Description of problem:

The authoring kit details panel is:

a) extremely confusing (full of random class names)
b) fragile (there's no validation on component name, for example, so
if you create an invalid component, it gets saved, and you are unable
to author any Content item because the authoring kit wizard
instantiates all authoring kit components)

Solution:

I propose that we remove this panel altogether. IIRC, this was
actually an early APLAWS fork. I'm not sure why it's back in. Dan, can
you comment?
Comment 1 Daniel Berrange 2004-02-27 05:42:46 EST
Yeah it was a temporary hack because there was no way to add generic
assets to all authnoring kits. Since i created the
'ContentAssetInitializer' concept its basically redundant & dangerous.
I also think it will break CMS because it doesn't refresh the item.jsp
page to include the components. I had thought about making its
visibiloity a config option (bug 116148), but I think we'll be safer
removing it altogether.
Comment 2 Richard Li 2004-02-27 08:58:15 EST
removed @40839

Note You need to log in before you can comment on or make changes to this bug.