Bug 1169630 - IDE ATAPI devices do not respond to VPD inquiries
Summary: IDE ATAPI devices do not respond to VPD inquiries
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: John Snow
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1169595
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-02 05:04 UTC by langfang
Modified: 2015-03-17 00:56 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1169595
Environment:
Last Closed: 2015-02-02 17:17:38 UTC


Attachments (Terms of Use)

Comment 2 John Snow 2014-12-08 22:01:33 UTC
Fix pending upstream; http://lists.gnu.org/archive/html/qemu-devel/2014-12/msg00568.html

Comment 3 John Snow 2015-02-02 17:17:38 UTC
Closing this as NOTABUG: After discussions with the author of sg3_utils, it has come to light that most ATAPI devices generally do not claim compliance with this specification and it is not expected that these devices will adhere to the current version of the specification.

As such, do not use sg3_utils with the --id flag or --page=0x83 to try to get the WWN of an ATAPI device. Use --ata instead.


Note You need to log in before you can comment on or make changes to this bug.