Bug 1169662 - [Fedora] RFE: Language display name should be customizable
[Fedora] RFE: Language display name should be customizable
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: 3.7
Assigned To: Alex Eng
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-02 01:52 EST by Noriko Mizumoto
Modified: 2015-07-21 22:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-2758)
Doc Type: Bug Fix
Doc Text:
Story Points: 1
Clone Of:
Environment:
Last Closed: 2015-07-21 22:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2014-12-02 01:52:52 EST
Hi

Let's back to basic, it will be best to stick with the team page which has been created by each coordinator who knows their language best. I looked the team page closely, and would like to have the following modification for the language list to match with the team page.

[Change]
Baluchi => Balochi
Chinese (China) => Chinese (Simplified)
Chinese (Hong Kong SAR China) => Chinese (Hong Kong)
Chinese (Taiwan) => Chinese (Traditional)
English (United Kingdom) => English (British)
wba => Warao

[Add]
Twi (tw)

[Remove]
Akan (ak)

Thanks

noriko
Comment 1 Noriko Mizumoto 2014-12-02 02:14:43 EST
Change the summary.

The problem is: 
The language list in zanata and the Fedora language team list are not consistent.
Comment 2 Ding-Yi Chen 2014-12-02 02:50:42 EST
I have added Twi (TW) and disabled Akan (ak).

Making Language name customizable will fulfill Noriko's request.

This may also benefit for wikipedia-like language teams,
e.g. zh@classical (Classical Chinese, 古文, gǔwén, "ancient text")
and en@simple (Simple English)

Requirements:
 1. Only admin can customize the name.
 2. Admin can enter a new name, then either confirm or cancel the change.
 3. Admin can reset the name to original system default.
 4. The confirmed/reset change should be shown in:
    a. Language list (Click "Language")
    b. Project-version page, both Languages tab and document tab
 5. The language team page (Click "Language-> <TEAM>") should show 
    a. The confirmed/reset language name
    b. Language name in its own script name (e.g. 中文(台灣))
Comment 3 Alex Eng 2015-02-12 04:38:19 EST
Pull request:
https://github.com/zanata/zanata-server/pull/692
Comment 4 Damian Jansen 2015-02-22 19:25:53 EST
Verified merge (master) at 81054b713c3d9b1e1962915188c8d40c6513c0b5

Note You need to log in before you can comment on or make changes to this bug.