Bug 1169790 - [USS] : After restore entering into .snaps from sub directory fails in NFS mount until we do drop_caches.
Summary: [USS] : After restore entering into .snaps from sub directory fails in NFS mo...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard: USS
Depends On:
Blocks: 1153907
TreeView+ depends on / blocked
 
Reported: 2014-12-02 13:08 UTC by Sachin Pandit
Modified: 2018-04-16 16:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
When a volume is down and there is an attempt to access .snaps directory, a negative cache entry is created in the Kernal Virtual File System(VFS) cache for .snaps. After the volume is brought back online accessing .snaps still fails with an ENOENT error because of the negative cache entry. Workaround: Clear the kernel VFS cache by executing the following command: # echo 3 >/proc/sys/vm/drop_caches
Clone Of:
Environment:
Last Closed: 2018-04-16 16:03:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sachin Pandit 2014-12-02 13:08:39 UTC
Description of problem:
After restore entering into .snaps from sub directory fails until we do drop_caches.


Version-Release number of selected component (if applicable):
glusterfs 3.6.0.35


How reproducible:
2/2

Steps to Reproduce:
1) Create a 2x2 dist rep volume and start it 
2) Fuse and NFS mount the volume, enable USS
3) Create a directory "dir" on main volume
4) Take a snapshot "snap1"
5) "cd" to "<nfs_mnt>/dir/.snaps/snap1"
6) deactivate and restore to snap1
7) try to "cd" to "<nfs_mnt>/dir/.snaps/" -> This fails as expected
8) create a snapshot snap1
9) try to "cd" to "<nfs_mnt>/dir/.snaps/" -> Not expected
   But from fuse mount the same step workds


Actual results:
After restore entering into .snaps from sub directory fails until we do drop_caches.

Expected results:


Additional info:

Comment 2 Sachin Pandit 2014-12-02 13:41:33 UTC
Rajesh, does the Doc text looks fine ?

Comment 4 Pavithra 2014-12-16 06:48:59 UTC
Hi Rajesh,

I edited the known issue doc text you provided. Can you please review the doc text for technical accuracy and sign off?

Comment 5 Pavithra 2014-12-17 03:59:58 UTC
Made a small edit.


Note You need to log in before you can comment on or make changes to this bug.