Bug 116998 - Can some of ESR's complaints be addressed?
Can some of ESR's complaints be addressed?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://www.catb.org/~esr/writings/cup...
: FutureFeature
Depends On: 90946
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 03:00 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 08:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-02-27 03:00:18 EST
In http://www.catb.org/~esr/writings/cups-horror.html ESR describes a
number of problems he had using r-c-p in Fedora Core 1. In the
corresponding SlashDot article
http://developers.slashdot.org/article.pl?sid=04/02/27/0043250&mode=thread
several people confirmed that they had similar problems with r-c-p. I
also have to agree - r-c-p is not very intuitive and certain things,
_especially_ configuring several Fedora machines to access a printer
attached to one of them should be much easier to do.

Can some of ESR problems with r-c-p be addressed and some of his
suggestions implemented?
Comment 1 Tim Waugh 2004-02-28 17:57:00 EST
Ideas to make it better:

o Put a 'Sharing...' button on the edit dialog, to bring up the
sharing dialog

o Remove 'CUPS' as an option for queue type, or else put text on that
screen saying 'this probably isn't what you want -- instead make sure
that browsing is working by ...'

o Default the 'Automatically find remote queues' check-button to on

o Make queue list window indicate whether each queue is shared or private

Others?
Comment 2 Michel Alexandre Salim 2004-02-28 22:37:30 EST
'Sharing' as in, using Samba to share the printer? The simple way
would be to create a raw queue and share that (Windows users get to
use vendor-supplied print drivers); would be nice to have
sys-conf-print to ask for the vendor CD and copy the files from it.

Otherwise, if CUPS' postscript driver is to be installed on the
Windows clients, give the option to download and install it
automatically (using cupsaddsmb). Unfortunately it's developed using
Windows Driver SDK and can't be redistributed, but the print admin
should be given the option to point sys-conf-print at another location
(on CD, on a network share etc.)

Caveat on using Samba raw print queue sharing: recent Winprinters
might require each Windows user to be a print admin in order to print.
Silly consumer items not meant for multi-user operations, but that's
what a lot of users have.
Comment 3 Tim Waugh 2004-02-29 07:09:46 EST
No, nothing to do with samba at all.
Comment 4 Tim Waugh 2004-03-10 08:17:35 EST
o Default the 'Automatically find remote queues' check-button to on

This point is already done actually, and in fact should have been the
case since CUPS browsing was added to the config tool.  I guess the
real problem is the firewall rules (see bug #90946).
Comment 5 Tim Waugh 2004-03-10 10:35:06 EST
o Put a 'Sharing...' button on the edit dialog, to bring up the
sharing dialog

This point is added in system-config-printer-0.6.96-1.
Comment 6 Tim Waugh 2004-03-24 10:48:05 EST
o Make queue list window indicate whether each queue is shared or private

This point is added in system-config-printer-0.6.98-1.

Note You need to log in before you can comment on or make changes to this bug.