Bug 116999 - redhat-config-users crashes when adding a user without a built-in group or home directory
redhat-config-users crashes when adding a user without a built-in group or ho...
Status: CLOSED DUPLICATE of bug 89895
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 03:02 EST by will jaspers
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description will jaspers 2004-02-27 03:02:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I cannot add a user without a built-in group or home directory.
This is annoying as hell, especially since I work with MySQL a LOT 
and am trying to create a user that will never have access to any 
other packages (than MySQL) on my machine.

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1. connect to your redhat machine, REMOTELY with VNC
2. log in as the root user
3. run : redhat-config-users
4. enter some data for a NEW user:
   username, password, confirm password,
5. choose login shell:
   /sbin/nologin
6. UNCHECK Create Home Directory
7. UNCHCEK Create a private group for the user
8. PRESS "OK"
    

Actual Results:  [root@mytoast joeb]# redhat-config-users
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userWindow.py", line 315, in 
on_userWin_ok_button_clicked
    self.addToUsersGroup(userEnt, userName)
  File "/usr/share/redhat-config-users/userWindow.py", line 332, in 
addToUsersGroup
    cn = groupEnt.get(libuser.GROUPNAME)[0]
AttributeError: 'NoneType' object has no attribute 'get'


Expected Results:  It should have created a new user for me, but it 
freaked out and the GUI locked up for this component.

Additional info:
Comment 1 Brent Fox 2004-03-11 14:44:59 EST

*** This bug has been marked as a duplicate of 89895 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.