Bug 117007 - Install not possible in Russian (probably also Arabic and Hebrew)
Install not possible in Russian (probably also Arabic and Hebrew)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-27 06:45 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 11:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-02-27 06:45:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031015 Firebird/0.7

Description of problem:
If Russian is selected as the installation language, installation
is not possible (without specialized undocumented knowledge).  The
problem is that the  keyboard is left by default in Russian mode, when
it should be English.  So when the time comes to enter the root
password, the installer always rejects the password, complaining that
it contains non-ascii characters.
The problem is aggravated by the fact that the password itself is not
displayed, so the user has no way of knowing that he is entering
Russian text.


Version-Release number of selected component (if applicable):
rhpl-0.124.1-1

How reproducible:
Always

Steps to Reproduce:
1. Select Russian as installation language.
2. Accept all defaults.
3. Try to enter root password.

    

Actual Results:  Installer repeatedly rejects password, complaining
about non-ascii characters.
Screen displays only asterisks, so user has no idea that he is
entering Cyrillic text. 
User gives up in despair and switches to Suse.

Expected Results:  Keyboard should be in English mode by default.

Additional info:

In the module 'keyboard_models.py' the ru keyboard is defined like this:
'ru' : [_('Russian'), 'ru,us', 'pc105', '', . . . 
The second element is 'ru,us', but it should be 'us,ru'.

This problem presumably affects all languages which require a "shift"
key (Hebrew, Arabic, etc).
Comment 1 Jeremy Katz 2004-03-04 18:33:36 EST
Fixed in CVS 
Comment 2 Seth Vidal 2004-05-07 11:54:31 EDT
Fixed in CVS sounds like a closer

Note You need to log in before you can comment on or make changes to this bug.