This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 117020 - FC2 test1 include/version.h says 2.4.20
FC2 test1 include/version.h says 2.4.20
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks: 115707
  Show dependency treegraph
 
Reported: 2004-02-27 09:58 EST by Jerry Geis
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 12:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Geis 2004-02-27 09:58:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
the include/version.h file in FC2 - test1 
says 2.4.20

Should it not be 2.6.1



Version-Release number of selected component (if applicable):
kernel 2.6.1-1.65smp

How reproducible:
Always

Steps to Reproduce:
1.Mentioned above
2.
3.
    

Expected Results:  I expected 2.6.1

Additional info:
Comment 1 Arjan van de Ven 2004-02-27 10:16:39 EST
this is the userspace headers not the kernel headers.. so who cares ?
Comment 2 Jerry Geis 2004-02-27 10:25:45 EST
doing rpm -qa | grep headers

gives

glic-kernheaders-2.4-8.43
glib-headers-2.3.3-7
Comment 3 Arjan van de Ven 2004-02-27 10:32:13 EST
and this is a problem...why ?
Comment 4 Jerry Geis 2004-02-27 10:36:24 EST
It is a problem as the software I am compiling is 
reporting it as a problem.

It is saying the kernel I am running does not match
the version.h 

The kernel I am running is 2.6.1-1.65smp and the version.h
file indicates a 2.4 kernel not a 2.6 kernel.

That is why I reported it.
Comment 5 Arjan van de Ven 2004-02-27 10:37:51 EST
that software doesn't happen to be a kernel module?
If so it is very broken in using the glibc header....
Comment 6 lilka 2004-03-10 15:18:02 EST
I have a bad news for Arjan.
Please download kernel-source-2.6.1-1.65.i386.rpm 
And check to see that is MISSING linux/version.h 

Please help to fix it. 

Full install of FC2 test 1.
Comment 7 Arjan van de Ven 2004-03-10 15:20:13 EST
lilka: and that is a problem... why?
kernel-source is not for providing headers for *ANYTHING*
Comment 8 Rick Johnson 2004-03-14 12:19:33 EST
Here's one place where using 2.4 headers is causing a problem - see
bug 115707

Wireless tools includes wireless.h from /usr/include/linux/wireless.h
(part of glibc-kernheaders). This header is version 15 and (among many
others) is from the 2.4. kernel. The kernel modules that this toolkit
controls are built from the 2.6 kernel headers, which includes version
16 of wireless.h. The toolkit complains of a version mismatch during
build and use which ultimately breaks wireless in many cases under FC2
Test 1 due to changes between the versions. My fix in order to
properly build the wireless-tools was to erase /usr/include/linux, and
then copy /lib/modules/<2.6-kernel>/build/include/linux to it's place. 

In my opinion, a distro based on the 2.6 kernel should use 2.6 kernel
headers for building tools, not something from 2.4. As long as other
tools aren't broken, I'd like to see 2.6 kernel headers within that
directory so that tools such as wireless-tools do build properly. 
Comment 9 David Woodhouse 2005-04-15 12:29:39 EDT
The wireless tools are a completely separate issue to the random numbers we may
or may not choose to include in version.h.
Comment 10 Mike A. Harris 2005-04-15 15:26:39 EDT
This bug is bogus, and changing version.h just broke xorg-x11 from
compiling.  Please change this back to what it was before.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=155025
Comment 11 David Woodhouse 2005-04-15 16:02:08 EDT
Both bugs are bogus. _Nothing_ should depend on the value of version.h.
Reverting for now, but don't count on it staying like that.

Note You need to log in before you can comment on or make changes to this bug.