Bug 117021 - iconv aborts conversion with '-c'
iconv aborts conversion with '-c'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 118961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 10:31 EST by Thomas Woerner
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 05:48:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Input file (30.16 KB, text/plain)
2004-02-27 10:32 EST, Thomas Woerner
no flags Details

  None (edit)
Description Thomas Woerner 2004-02-27 10:31:04 EST
Description of problem:
"/usr/bin/iconv -c -f utf-8 -t ISO-8859-1" stops conversion of
attached file before EOF.

Version-Release number of selected component (if applicable):
glibc-common-2.3.3-8

How reproducible:
always

Steps to Reproduce:
1. "/usr/bin/iconv -c -f utf-8 -t ISO-8859-1 <file>"
2.
3.
  
Actual results:
Short file

Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-02-27 10:32:09 EST
Created attachment 98103 [details]
Input file
Comment 2 Thomas Woerner 2004-03-08 05:48:19 EST
glibc-2.3.3-14 is fixing this problem.
Comment 3 Jakub Jelinek 2004-03-23 04:51:15 EST
*** Bug 118961 has been marked as a duplicate of this bug. ***
Comment 4 Jay Turner 2004-09-02 01:57:33 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-384.html

Note You need to log in before you can comment on or make changes to this bug.