Bug 117025 - RPM config shouldn't set LANG=C
RPM config shouldn't set LANG=C
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 11:10 EST by Owen Taylor
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 11:05:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2004-02-27 11:10:55 EST
I don't think setting LANG=C is a good idea; in particular,
the C locale has a CTYPE that only allows ASCII characters,
so text utilities can't process internationlized text in
the C locale.

Possible downside:

 - Scripts may be broken; e.g., use [A-Z] to match
   only ASCII characters

I don't think this will actually be a big problem because
packages presumably get build occasionally without 
redhat-rpm-config, but it probably is best to do it not
at a critical time in a release cycle.

It was proposed that a downside was that only certain
translations would get installed, but that is LINGUAS,
not LANG. LANG has no effect on installed translations.
Comment 1 Elliot Lee 2004-02-27 11:13:27 EST
This change sounds fine, but just needs to be checked for side effects
- perhaps by doing a mass rebuild in an environment that includes the
redhat-rpm-config, and then checking the file lists of the resulting
packages.
Comment 2 Owen Taylor 2004-12-02 17:03:02 EST
If the NEEDINFO means you are waiting for me to do such
a test, you might as well close the bug now, there is no chance
I'll have the time to do that.

Note You need to log in before you can comment on or make changes to this bug.