This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11703 - PCMCIA Network Dropping Interrupts
PCMCIA Network Dropping Interrupts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-26 23:37 EDT by tix
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 18:38:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tix 2000-05-26 23:37:59 EDT
Using RH6.2 Workstation install (with applicable updates), started getting
kernel error messages after switching from KDE to GNOME.
Error is:
kernel: eth0: interrupt(s) dropped!

This causes all network activity to stop and the pcmcia service must be
restarted.
I installed KDE as my desktop environment WITHOUT any Gnome components.
Upon installing Gnome and Helix, started getting the above errors at random
intervals ranging from 1 sec to hours after restarting the pcmcia service.

The module man page states:
eth#: interrupt(s) dropped!
Indicates that the driver did not receive an interrupt notification for
some reason. The driver will poll the card (with a significant performance
penalty) if the problem persists. The most likely cause is an interrupt
conflict and/or host bridge configuration problem.

I suspect this is related to ESD as it was not installed prior to Gnome and
did not have this message until this time.  Can this be confirmed?  Any
work-arounds?  I tried turning off sound events and even the sound server
in Gnome-config without change.

Have tried changing the module "max_interrupt_work" and "irq_list" options
in /etc/pcmcia/config.opts to no avail.

Configuration as follows:
Toshiba Tecra 550CDT Laptop
4 G HDD
160 M Mem
Have ran RH on this laptop since 5.1  :-)
Comment 1 Alan Cox 2000-08-08 17:39:21 EDT
Do you see this problem with the RH gnome rpms installed, or just Helix ?
Comment 2 Alan Cox 2002-12-14 18:38:55 EST
No answer in 18 months

Note You need to log in before you can comment on or make changes to this bug.