Bug 1170556 - rhncfg-manager: XML-RPC error while talking to https://spacewalk/CONFIG-MANAGEMENT-TOOL: cannot marshal None unless allow_none is enabled
rhncfg-manager: XML-RPC error while talking to https://spacewalk/CONFIG-MANAG...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
2.2
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On: 1148250
Blocks: space23
  Show dependency treegraph
 
Reported: 2014-12-04 05:25 EST by Krzysztof Pawłowski
Modified: 2015-04-14 15:03 EDT (History)
0 users

See Also:
Fixed In Version: rhncfg-5.10.79
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-14 15:03:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Pawłowski 2014-12-04 05:25:38 EST
Description of problem:

After upgrade to 2.2 there is a problem with uploading files to configuration channel with rhncfg-manager


Version-Release number of selected component (if applicable):

Client:
rhncfg-client-5.10.73-1.el6.noarch
rhn-custom-info-5.4.26-1.el6.noarch
rhnsd-5.0.14-1.el6.x86_64
rhnlib-2.5.72-1.el6.noarch
rhncfg-5.10.73-1.el6.noarch
rhn-setup-2.2.7-1.el6.noarch
rhn-check-2.2.7-1.el6.noarch
rhncfg-actions-5.10.73-1.el6.noarch
rhn-client-tools-2.2.7-1.el6.noarch
yum-rhn-plugin-2.2.7-1.el6.noarch
rhncfg-management-5.10.73-1.el6.noarch
spacewalk-backend-libs-2.2.43-1.el6.noarch

Server:
spacewalk-backend-config-files-2.2.43-1.el6.noarch
spacewalk-sniglets-2.2.33-1.el6.noarch
spacewalk-common-2.2.2-1.el6.noarch
spacewalk-monitoring-selinux-2.2.1-1.el6.noarch
spacewalk-taskomatic-2.2.126-1.el6.noarch
spacewalk-setup-2.2.13-1.el6.noarch
spacewalk-backend-xmlrpc-2.2.43-1.el6.noarch
spacewalk-admin-2.2.5-1.el6.noarch
spacewalk-backend-server-2.2.43-1.el6.noarch
spacewalk-base-minimal-config-2.2.33-1.el6.noarch
spacewalk-backend-libs-2.2.43-1.el6.noarch
spacewalk-schema-2.2.33-1.el6.noarch
spacewalk-html-2.2.33-1.el6.noarch
spacewalk-jpp-workaround-2.2.3-1.el6.noarch
spacewalk-base-minimal-2.2.33-1.el6.noarch
spacewalk-backend-xml-export-libs-2.2.43-1.el6.noarch
spacewalk-backend-applet-2.2.43-1.el6.noarch
spacewalk-base-2.2.33-1.el6.noarch
spacewalk-grail-2.2.33-1.el6.noarch
spacewalk-postgresql-2.2.2-1.el6.noarch
spacewalk-backend-2.2.43-1.el6.noarch
spacewalk-backend-sql-2.2.43-1.el6.noarch
spacewalk-backend-iss-export-2.2.43-1.el6.noarch
spacewalk-monitoring-2.2.1-1.el6.noarch
spacewalk-selinux-2.2.1-1.el6.noarch
spacewalk-search-2.2.8-1.el6.noarch
spacewalk-repo-2.2-1.el6.noarch
spacewalk-java-postgresql-2.2.126-1.el6.noarch
spacewalk-java-lib-2.2.126-1.el6.noarch
spacewalk-backend-app-2.2.43-1.el6.noarch
spacewalk-backend-package-push-server-2.2.43-1.el6.noarch
spacewalk-backend-tools-2.2.43-1.el6.noarch
spacewalk-branding-2.2.5-1.el6.noarch
spacewalk-utils-2.2.25-1.el6.noarch
spacewalk-setup-jabberd-2.0.1-1.el6.noarch
spacewalk-backend-config-files-common-2.2.43-1.el6.noarch
spacewalk-pxt-2.2.33-1.el6.noarch
spacewalk-dobby-2.2.33-1.el6.noarch
spacewalk-slf4j-1.6.1-6.el6.noarch
spacewalk-config-2.2.2-1.el6.noarch
spacewalk-backend-sql-postgresql-2.2.43-1.el6.noarch
spacewalk-doc-indexes-2.2.2-1.el6.noarch
rhn-org-httpd-ssl-key-pair-spacewalk.icore-1.0-1.noarch
spacewalk-java-config-2.2.126-1.el6.noarch
spacewalk-backend-iss-2.2.43-1.el6.noarch
spacewalk-reports-2.2.15-1.el6.noarch
spacewalk-certs-tools-2.2.1-1.el6.noarch
spacewalk-backend-config-files-tool-2.2.43-1.el6.noarch
spacewalk-java-2.2.126-1.el6.noarch



How reproducible:
Some files always works, some files always broken

Steps to Reproduce:
1. rhncfg-manager add /etc/squid/squid.conf -c centos-6-squid


Actual results:
XML-RPC error while talking to https://spacewalk/CONFIG-MANAGEMENT-TOOL: cannot marshal None unless allow_none is enabled


Expected results:
Local file /etc/squid/squid.conf -> remote file /etc/squid/squid.conf


Additional info:
Comment 1 Stephen Herr 2014-12-04 08:43:02 EST
I'm guessing that the problem is that files that do not have an SELinux context cause this exception. Can you check for me?

$ ls -Z /etc/squid/squid.conf

That is a known problem with the current rhncfg* packages that should be fixed in Spacewalk nightly. You can also try installing the newest rhncfg* packages from the Spacewalk nightly repo to see if that solves the problem.

http://yum.spacewalkproject.org/nightly-client/
Comment 2 Krzysztof Pawłowski 2014-12-04 10:04:17 EST
-rw------- root root ?                                /etc/squid/squid.conf

We have SELinux disabled.
Comment 3 Stephen Herr 2014-12-04 11:51:40 EST
In that case the fix is already committed to Spacewalk master:
102ffed86c3bc0ecbb73c3bb3b0b354eab7a8365
Comment 4 Stephen Herr 2014-12-04 11:54:19 EST
Actually this commit is the correct one:
473681d5a0e5240b3294e4057ce224d43c01a1ea
Comment 5 Grant Gainey 2015-03-23 12:59:03 EDT
Moving bugs to ON_QA as we move to release Spacewalk 2.3
Comment 6 Grant Gainey 2015-04-14 15:03:08 EDT
Spacewalk 2.3 has been released. See

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes23

Note You need to log in before you can comment on or make changes to this bug.