Bug 1170631 - If connection to DB fails , the job that checks DisconnectDwh flag does not reconnect to engine db
Summary: If connection to DB fails , the job that checks DisconnectDwh flag does not r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 1170501 1181616
Blocks: 1181642
TreeView+ depends on / blocked
 
Reported: 2014-12-04 13:44 UTC by Shirly Radco
Modified: 2016-03-09 21:22 UTC (History)
10 users (show)

Fixed In Version: OVIRT 3.6.0-1 first release
Doc Type: Bug Fix
Doc Text:
Previously, when the connection to the database failed the job that checked the 'DisconnectDwh' flag did not reconnect to the engine database and this meant that the ETL did not stop. Now, the job that checks the 'DisconnectDwh' flag keeps trying to connect to the database if the connection fails.
Clone Of: 1170501
: 1181642 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:22:08 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0404 normal SHIPPED_LIVE rhevm-dwh bug fix and enhancement update 2016-03-10 01:29:45 UTC
oVirt gerrit 35878 master MERGED history: maintain db connection for DisconnectDwh check Never

Description Shirly Radco 2014-12-04 13:44:14 UTC
+++ This bug was initially created as a clone of Bug #1170501 +++

Description of problem:
If connection to DB fails , the job that checks "DisconnectDwh" flag does not reconnect to engine db.

Version-Release number of selected component (if applicable):
3.5

How reproducible:
100%

Steps to Reproduce:
1. Have engine, dwh running
2. Restart postgresql
3. Change value of "DisconnectDwh" to 1

Actual results:
The ETL does not stop

Expected results:
ETL should stop

Additional info:

Comment 3 errata-xmlrpc 2016-03-09 21:22:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0404.html


Note You need to log in before you can comment on or make changes to this bug.