Bug 1170681 - avahi-libs should not require avahi
Summary: avahi-libs should not require avahi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: avahi
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Jakub Prokes
URL:
Whiteboard:
Depends On: 913168
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-04 15:31 UTC by Frank Ch. Eigler
Modified: 2015-03-16 12:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 913168
Environment:
Last Closed: 2015-03-05 13:34:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0603 normal SHIPPED_LIVE avahi bug fix update 2015-03-05 17:20:05 UTC

Description Frank Ch. Eigler 2014-12-04 15:31:38 UTC
+++ This bug was initially created as a clone of Bug #913168 +++

The dependency added in this commit does not seem right:

commit 661b35b0ba7b3752e02261c0ddf601a826102d7e
Author: Matthias Clasen <mclasen@redhat.com>
Date:   Fri Feb 1 15:26:42 2013 -0500

    tighten inter-subpackage symlinks

...
@@ -247,6 +249,7 @@ Mono programs that use avahi-ui.
 
 %package libs
 Summary:          Libraries for avahi run-time use
+Requires:         %{name} = %{version}-%{release}


The main package already has a versioned dependency on the avahi-libs subpackage, which is alright. But the dependency in the opposite direction is wrong.

[...]

This problem has been corrected on Fedora 20+, but the correction needs to
be backported to RHEL-7.

Comment 1 Michal Sekletar 2014-12-04 15:56:04 UTC
Minor specfile only change. Proposing for RHEL-7.2 fastrack. Unfortunately it is too late for RHEL-7.1.

Comment 18 errata-xmlrpc 2015-03-05 13:34:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0603.html

Comment 19 Laszlo Ersek 2015-03-14 00:05:01 UTC
I don't know how this bug was fixed, but avahi is completely un-upgradeable from 0.6.31-13.el7 to 0.6.31-14.el7, with yum.

Error: avahi-libs conflicts with avahi-0.6.31-14.el7.x86_64

Comment 20 Laszlo Ersek 2015-03-14 00:09:47 UTC
By that I mean that apparently one has to force-remove avahi, before upgrading the libraries (and then optionally reinstalling avahi):

# rpm --erase --nodeps avahi

Comment 21 Michal Sekletar 2015-03-16 11:51:16 UTC
Can you please provide a list of avahi packages on your system and yum error output when you try to upgrade avahi?

Comment 22 Laszlo Ersek 2015-03-16 12:09:23 UTC
I'm sorry, I can't reproduce those errors any longer. I worked it around as described in comment 20. The update I tried to exec was from 0.6.31-13.el7 to 0.6.31-14.el7.

That said, I've seen this kind of error with other (independent) packages at other times. If there is an incorrect circular dependency between packages, and that cycle is broken in a later spec update, I guess it might not be possible to perform update at all, without manually breaking the cycle first in the installed rpmdb.

BTW: while I was googling for a prior report, I found bug 1199462. That report seems to capture a very similar (if not exactly same) update error, except it seems to attribute the error to gnome-shell-browser-plugin. In my case, gnome-shell-browser-plugin was nowhere around, I just got the avahi conflicts that are listed in bug 1199462 comment 0,

Comment 23 Laszlo Ersek 2015-03-16 12:09:48 UTC
Sorry, that should have been a period (.). I don't have anything else to add.


Note You need to log in before you can comment on or make changes to this bug.