Bug 1170746 - CVE-2014-9278 openssh: ~/.k5users unexpectedly grants remote login [fedora-all]
Summary: CVE-2014-9278 openssh: ~/.k5users unexpectedly grants remote login [fedora-all]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 20
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: CVE-2014-9278
TreeView+ depends on / blocked
 
Reported: 2014-12-04 18:40 UTC by Florian Weimer
Modified: 2015-02-25 09:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-25 09:39:52 UTC
Type: ---


Attachments (Terms of Use)

Description Florian Weimer 2014-12-04 18:40:58 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When submitting as an update, use the fedpkg template provided in the next
comment(s).  This will include the bug IDs of this tracking bug as well as
the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
fedpkg commit message.

NOTE: this issue affects multiple supported versions of Fedora. While only
one tracking bug has been filed, please correct all affected versions at
the same time.  If you need to fix the versions independent of each other,
you may clone this bug as appropriate.

[bug automatically created by: add-tracking-bugs]

Comment 1 Florian Weimer 2014-12-04 18:41:06 UTC
Use the following template to for the 'fedpkg update' request to submit an
update for this issue as it contains the top-level parent bug(s) as well as
this tracking bug.  This will ensure that all associated bugs get updated
when new packages are pushed to stable.

=====

# bugfix, security, enhancement, newpackage (required)
type=security

# testing, stable
request=testing

# Bug numbers: 1234,9876
bugs=1169843,1170746

# Description of your update
notes=Security fix for CVE-2014-9278

# Enable request automation based on the stable/unstable karma thresholds
autokarma=True
stable_karma=3
unstable_karma=-3

# Automatically close bugs when this marked as stable
close_bugs=True

# Suggest that users restart after update
suggest_reboot=False

======

Additionally, you may opt to use the bodhi update submission link instead:

https://admin.fedoraproject.org/updates/new/?type_=security&bugs=1169843,1170746

Comment 2 Jakub Jelen 2015-02-25 09:16:41 UTC
Hello Florian,
we are really sorry but it happened that we pushed build without this template and with wrong/missing bz# so this bugzilla is still here unaffected even though it is resolved issue. Can you please have a look and let me know what should be the next steps about this?

Bug was fixed in these builds:
openssh-6.4p1-8.fc20
openssh-6.6.1p1-11.1.fc21
openssh-6.7.1p1-1.fc22

Comment 3 Florian Weimer 2015-02-25 09:39:52 UTC
Thanks, I noted the fixed packages in the flaw bug.


Note You need to log in before you can comment on or make changes to this bug.