Bug 117076 - Unable to unmount USB disk
Unable to unmount USB disk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Target FC3Target
  Show dependency treegraph
 
Reported: 2004-02-27 19:15 EST by Brian G. Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 08:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2004-02-27 19:15:38 EST
Description of problem:
I have one of those flash drive USB key disks.

First of all I don't have a "Disks" sub menu when right clicking on
the gnome desktop.  I have to mount from the command line.

After mounting it, it appears on the desktop with the read-only emblem
even though I can open it and write to it.  This may be a different
bug, since all my desktop items have the read only emblem.

Since there is no "Disk" menu I have to umount it from the command
line.  However, the disk is always busy even when I have closed all my
applications.  I do a "lsof" and I don't see any processes with it
open.  Only when "telinit 3" to get out of gnome can I unmount the disk.


Version-Release number of selected component (if applicable):
gnome-desktop-2.5.90-1

How reproducible:
always


Steps to Reproduce:
1.mount usb disk
2.umount usb disk
3.
  
Actual results:
device always busy

Expected results:
unmount disk


Additional info:
Comment 1 Alexander Larsson 2004-08-26 09:08:04 EDT
Unmount it by right clicking on the disk and select unmount.
Does that work?
Comment 2 Brian G. Anderson 2004-08-27 11:29:39 EDT
This problem no longer occurs with the most recent kernel and initscripts.

I can unmount it using the right-click or using the disk mount panel
applete
Comment 3 Alexander Larsson 2004-09-02 08:10:26 EDT
ok.

Note You need to log in before you can comment on or make changes to this bug.