Bug 1170928 - v1/search API doesn't work
Summary: v1/search API doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-distribution
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Michal Minar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-05 06:40 UTC by Etsuji Nakai
Modified: 2016-10-06 15:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-06 15:27:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Etsuji Nakai 2014-12-05 06:40:46 UTC
Description of problem:

docker-registry's search API (v1/search) doesn't return correct information.

Version-Release number of selected component (if applicable):

docker-registry-0.6.8-8.el7.noarch
docker-1.2.0-1.8.el7.x86_64

How reproducible:

# yum -y install dcoker docker-registry

** Prepare the local image as localhost:5000/rhel6:latest

# docker push localhost:5000/rhel6:latest

Then v1/repositories API returns correct information as below:

# curl http://localhost:5000/v1/repositories/rhel6/tags
{"latest": "1856bc3ea0b29e52cc0f086f2d48d8aa469d8177c4a9178c62299d61782d5f97"}

but v1/search API returns no entry:
# curl http://localhost:5000/v1/search
{"num_results": 0, "query": "", "results": []}

Expected results:

v1/search API shoud return the list of repositories.

Comment 3 Lokesh Mandvekar 2016-05-23 19:02:59 UTC
sorry about the delay on this. docker-registry has now been obsoleted by docker-distribution which should work with v1 too iiuc. Could you check if docker-distribution faces this issue as well?

Comment 4 Michal Minar 2016-10-06 15:27:27 UTC
The curl calls would look like this now:

`curl http://localhost:5000/v2/rhel6/tags/list`
`curl http://localhost:5000/v2/_catalog`

I'm closing this since this is reported against obsolete package. If you experience the same problem with docker-distribution as well, please reopen.


Note You need to log in before you can comment on or make changes to this bug.