Bug 1170966 - glusterbot has a broken regex s/substituion/replacing/ command
Summary: glusterbot has a broken regex s/substituion/replacing/ command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Joe Julian
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-05 08:42 UTC by Niels de Vos
Modified: 2016-10-18 15:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-18 15:03:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-12-05 08:42:46 UTC
From earlier today:

09:30 < ndevos> well, the client side needs to talk to the brick processes, if those are not runing, very little will work
09:30 < ndevos> s/runing/running/
09:30 <@glusterbot> What ndevos meant to say was: An error has occurred and has been logged. Please contact this bot's administrator for more information.
09:30 < ndevos> uh, no, that is not what I wanted to day
09:30 < tvb> ndevos: https://gist.github.com/tvb/6438d6718c88033cfc67
09:30 < ndevos> s/day/say/
09:30 <@glusterbot> What ndevos meant to say was: An error has occurred and has been logged. Please contact this bot's administrator for more information.


So, with this bug, I am contacting the administrator so that this does not get forgotten.

Comment 1 Nigel Babu 2016-10-18 12:43:25 UTC
I believe Joe has turned off the substitution, so I'm going to close this bug.

Comment 2 Niels de Vos 2016-10-18 13:14:08 UTC
Just tested this now in #gluster:

15:12 < ndevos> oh, its turned off?
15:12 < ndevos> s/off/on/
15:12 <@glusterbot> What ndevos meant to say was: oh, its turned on?

Comment 3 Kaushal 2016-10-18 14:08:07 UTC
(In reply to Niels de Vos from comment #2)
> Just tested this now in #gluster:
> 
> 15:12 < ndevos> oh, its turned off?
> 15:12 < ndevos> s/off/on/
> 15:12 <@glusterbot> What ndevos meant to say was: oh, its turned on?

It's working as expected. Was it supposed to do something different?

Comment 4 Niels de Vos 2016-10-18 15:03:05 UTC
(In reply to Nigel Babu from comment #1)
> I believe Joe has turned off the substitution, so I'm going to close this
> bug.

Sorry, I re-opened the bug because that ^^ is not correct. But the original problem seems to have been fixed, so I'll close it again :)


Note You need to log in before you can comment on or make changes to this bug.