This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11710 - ImageMagick-5.1.1-3 has broken dependencies
ImageMagick-5.1.1-3 has broken dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: ImageMagick (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-27 23:33 EDT by SB
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-27 23:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description SB 2000-05-27 23:33:04 EDT
ImageMagick-5.1.1-3.i386.rpm and ImageMagick-devel-5.1.1-3.i386.rpm
both require libbz2.so.0 AND libbz2.so.1 making it impossimble to
properly install the packages because bzip2 only provides one of
those and multiple bzip2 packages (i.e. 0.9.5x and 1.0.0) cannot
be installed at once it leaves them broken.

Quote from changelog:

* Wed May 17 2000 Trond Eivind Glomsrxd <teg@redhat.com>

- now compiles with bzip2 1.0
- changed buildroot to include version


Guess someone just forgot to remove the dependency from spec file.
The fix is simple, just remove bad dependency from spec file.

-Stan Bubrouski
Comment 1 Bernhard Rosenkraenzer 2000-06-12 16:31:21 EDT
Fixed.
The problem was a bit more complicated though, the dependence on libbz2.so.0 was
implicit (generated automatically because it linked to another library using
libbz2.so.0).

Note You need to log in before you can comment on or make changes to this bug.