Bug 1171121 - xorg-x11-server-Xorg-1.15.0-22.el6 not longer requires xorg-x11-drv-{vesa,evdev,void}
Summary: xorg-x11-server-Xorg-1.15.0-22.el6 not longer requires xorg-x11-drv-{vesa,evd...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
: 1156379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-05 11:54 UTC by Eduardo Minguez
Modified: 2015-07-22 05:51 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.15.0-28.el6
Doc Type: Bug Fix
Doc Text:
The X server package was missing requirements for basic drivers such as vesa, void, or evdev. With this update, installing the X server automatically pulls the basic required drivers as well.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:51:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1445 normal SHIPPED_LIVE xorg-x11-server bug fix and enhancement update 2015-07-20 18:44:00 UTC

Description Eduardo Minguez 2014-12-05 11:54:29 UTC
Description of problem:
Installing previous version of xorg-x11-server-Xorg installed some basic drivers as dependency, making the system usable, but in xorg-x11-server-Xorg-1.15.0-22.el6, dependencies of xorg-x11-drv-{vesa,evdev,void} are missing.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.15.0-22.el6

How reproducible:
Install xorg-x11-server-Xorg-1.15.0-22.el6

Steps to Reproduce:
1. Install xorg-x11-server-Xorg-1.15.0-22.el6
2. Check dependencies
3. Missing basic drivers

Actual results:
No basic drivers installed as in RHEL6.5

Expected results:
Basic xorg-x11-drivers installed

Additional info:
In previous xorg-x11-server specs, there was:

%ifarch %{ix86} x86_64
Requires: xorg-x11-drv-vesa
%else
Requires: xorg-x11-drv-fbdev
%endif
Requires: xorg-x11-drv-void xorg-x11-drv-evdev >= 2.1.0-3

that looks missing in current spec

Comment 4 Michal Domonkos 2015-02-02 17:43:46 UTC
*** Bug 1156379 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2015-07-22 05:51:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1445.html


Note You need to log in before you can comment on or make changes to this bug.