Bug 117113 - Kdevelop 3.01 immediately dies after creating a new PHP project from default
Kdevelop 3.01 immediately dies after creating a new PHP project from default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-28 13:44 EST by Tom Wittbrodt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 19:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wittbrodt 2004-02-28 13:44:15 EST
Description of problem:
Attempting to start a new PHP project in KDevelop 3.01 causes KDevelop
to crash.

Version-Release number of selected component (if applicable):
3.01

How reproducible:


Steps to Reproduce:
1. Start KDevelop
2. Choose Project -> New Project
3. Choose PHP -> Simple PHP Script
4. Assign Application Name (ie phptest4), click Next
5. Leave Version Control System as 'None', click Next
6. Use default template for .php files (appears to be GPL disclaimer),
click Finish

  
Actual results:
After clicking finish several things happen which appear to be the
setup of the project.  Briefly see a message "Finished", syntax
colored text appears in editing window then, Kdevelop dies and KDE
Crash handler appears

Expected results:
Default template PHP project template appears in editor for development

Additional info:

New project directory is created and contains 2 files, kdevelop
project file and php template file

Attempting to open this PHP project (KDevelop -> Project -> Open
Project) also causes KDevelop to die

Backtrace from KDE #0  0x00151a52 in _dl_sysinfo_int80 () from
/lib/ld-linux.so.2
#1  0x00400963 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x057f2831 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#3  <signal handler called>
#4  0x002237d9 in re_search_internal () from /lib/tls/libc.so.6
#5  0x002230ed in regexec () from /lib/tls/libc.so.6
#6  0x057ff992 in KRegExpPrivate::match(char const*) ()
   from /usr/lib/libkdecore.so.4
#7  0x057ffcd8 in KRegExp::match(char const*) () from
/usr/lib/libkdecore.so.4
#8  0x030c3945 in PHPParser::parseLines(QStringList*, QString const&) ()
   from /usr/lib/kde3/libkdevphpsupport.so
#9  0x08b3eb00 in ?? ()
#10 0x00000001 in ?? ()
#11 0x05880f58 in posix_memalign () from /usr/lib/libkdecore.so.4
#12 0x08e4c758 in ?? ()
#13 0x0309a818 in ?? () from /usr/lib/kde3/libkdevphpsupport.so
#14 0x08c61500 in ?? ()
#15 0x00160073 in _dl_tls_setup () from /lib/ld-linux.so.2
#16 0x0000098d in ?? ()
#17 0xbfe9f720 in ?? ()
#18 0x0813b910 in ?? ()
#19 0x08c6169c in ?? ()
#20 0x00000001 in ?? ()
#21 0x00000001 in ?? ()
#22 0x0813b910 in ?? ()
#23 0x0000233a in ?? ()
Comment 1 Ngo Than 2004-04-05 17:34:57 EDT
it looks like a bug in glibc. it can confirm this problem,
Comment 2 Ngo Than 2004-04-05 19:29:59 EDT
ok, it's a bug in kdevelop and is fixed now in kdevelop-3.0.2-2.

Note You need to log in before you can comment on or make changes to this bug.