Bug 117114 - Installer cannot find libgstcontrol-0.7.so.5 or libgstreamer-0.7.so.5
Installer cannot find libgstcontrol-0.7.so.5 or libgstreamer-0.7.so.5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-28 14:04 EST by Matthew Eastman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 10:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Eastman 2004-02-28 14:04:56 EST
Description of problem:
When running yum update, it fails to find all necessary dependencies.
 The missing ones are:
libgstcontrol-0.7.so.5
 - required by rhythmbox
libgstreamer-0.7.so.5
 - required by gnome-media, rhythmbox, nautilus-media

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. leave url in yum.conf as default:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/
2. run 'yum -y update' or 'yum update' as root


Actual Results:  Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.
Package rhythmbox needs libgstcontrol-0.7.so.5, this is not available.
Package gnome-media needs libgstreamer-0.7.so.5, this is not available.
Package rhythmbox needs libgstreamer-0.7.so.5, this is not available.
Package nautilus-media needs libgstreamer-0.7.so.5, this is not available.

Expected Results:  Updates complete with no problem

Additional info:
Comment 1 Martijn Bakker 2004-02-28 18:17:34 EST
not a bug in yum, but in libgstreamer.

Cause:
Certain files have a different name in the development version of
gstreamer-0.7.5-1. 

Possible solution #1:
Dependencies/buildlinks should be redone in rhythmbox, gnome-media and
nautilus-media, causing them to dynamically link against
libgstreamer-0.7.so.6 instead of libgstreamer-0.7.so.5.

Possible solution #2:
The build process of libgstreamer should be altered so it produces the
correct file(s).

(first bugzilla post, forgive me if I did wrong)
Comment 2 Jeff Johnson 2004-02-29 17:49:52 EST
Off to gstreamer for fix ...
Comment 3 John Thacker 2004-03-11 02:33:14 EST
Should be closed.  This is just a result of gstreamer's API changing
with the developmental version to require changing the library
version.  Rebuilding those packages, which has already happened in
Rawhide/Development, solves the problem.

Note You need to log in before you can comment on or make changes to this bug.