Bug 117125 - (SATA SIIMAGE IRQ?) Siimage SATA crashes box
(SATA SIIMAGE IRQ?) Siimage SATA crashes box
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 23:19 EST by Nathan B
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 23:30:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan B 2004-02-28 23:19:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I have an ASUS P4G8X motherboard which is using its Silicon Image 
striped RAID array (2 drives of 250GB each). Both Fedora Core 1 and 
Fedora Core 2 test1 crash when attempting to set the hostname upon 
booting. Hitting "Show Details" on the grey boot up screen shows 
nothing before the crash. 
This never happened to me before on the same hardware until I made 
use of the RAID functions on my Motherboard. Since then, Fedora won't 
boot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Booting Fedore Core 2 test1
2.
3.
    

Actual Results:  Kernal boots up, and the grey Fedora screen appears 
with the PC picutre, and swirling dots indicating init working.
The screen then displays that it is "Setting hostname". Then the 
swilring dots stop and the system crashes completely. Mouse is 
inactive.

Expected Results:  The system should have completed initialising.

Additional info:

I suspect my RAID is causing the crash. Fedora Core 1 worked before I 
installed a RAID. Since installing the RAID, neither Fedora 1 or 
Fedora Core 2 test1 boots up.
Comment 1 Nathan B 2004-02-28 23:20:04 EST
Sorry, my motherboard is the P4G(X deluxe, which has the RAID built in
Comment 2 Nathan B 2004-02-29 05:52:20 EST
Re-tested and verified that it is the P4G8X-Deluxe built in SATA RAID 
functions that are causing the crash. I unplugged my hard drives from 
the Serial-ATA RAID plugs and rebooted Fedora Core 2 test1 and the 
boot completed (although there were a few other bugs)
Comment 3 Bill Nottingham 2004-03-01 22:36:14 EST
Assigning to the kernel, the problem lies there if the raid driver is
crashing it.
Comment 4 Nathan B 2004-04-06 21:14:07 EDT
I tried playing with the acpi and apm during boot. Turning them both 
off doesn't fix the problem.

What I did notice is that the linux kernel relegates the RAID to IRQ 
9, but when I select the SMP kernel on my Hyper Threading P4, the 
IRQs get set to 209 (!!). Interestingly, IRQ 9 totally crashes my 
machine outright. IRQ 209 still crashes it and locks up the mouse, 
but the grey init screen swirling dots keep moving.
I have not tampered with my motherboard's BIOS.... but it seems the 
IRQ table the BIOS shows, displays that a lot of Serial and 
Multimedia devices are spead over IRQ 9.

It seems that the Linux kernel is misappropriating IRQs on my 
hardware setup.

I loaded up Knoppix on this machine, and noticed that sound no longer 
worked on it once RAID had been connected. So I'm lead to believe 
that this issue may be IRQ related in the linux kernel.

Windows works no problems. It seems to relegate the RAID drives to 
IRQ 23/24
Comment 5 Alan Cox 2004-05-03 14:29:28 EDT
You may want to try "acpi=off"

Comment 6 Dave Jones 2004-12-08 00:40:10 EST
any better with the 2.6.9 update ?
Comment 7 Nathan B 2004-12-08 23:26:13 EST
I went and tried FC3 and found that installation and booting works now without 
any problems. I haven't tried accessing the drives under FC3 (they are NTFS 
formatted anyway), but there are no crashes anymore.

Problem solved.

Note You need to log in before you can comment on or make changes to this bug.