Bug 1171319 - [abrt] plater: stltool.py:22:<module>:ImportError: No module named numpy
Summary: [abrt] plater: stltool.py:22:<module>:ImportError: No module named numpy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: printrun
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2d3e4d99909b26a15512badda41...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-05 21:47 UTC by Esa Varemo
Modified: 2015-01-07 01:24 UTC (History)
2 users (show)

Fixed In Version: printrun-2014.08.01-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-07 01:24:41 UTC


Attachments (Terms of Use)
File: backtrace (6.71 KB, text/plain)
2014-12-05 21:47 UTC, Esa Varemo
no flags Details
File: environ (1.39 KB, text/plain)
2014-12-05 21:47 UTC, Esa Varemo
no flags Details

Description Esa Varemo 2014-12-05 21:47:04 UTC
Description of problem:
Tried to launch plater after installing printrun with yum

Version-Release number of selected component:
plater-2014.07.30-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /usr/bin/plater
dso_list:       printrun-common-2014.07.30-2.fc21.x86_64
executable:     /usr/bin/plater
kernel:         3.17.4-300.fc21.x86_64+debug
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib64/python2.7/site-packages/printrun/stltool.py:22
#2 <module> in /usr/lib64/python2.7/site-packages/printrun/stlplater.py:35
#3 <module> in /usr/bin/plater:21

Comment 1 Esa Varemo 2014-12-05 21:47:10 UTC
Created attachment 965237 [details]
File: backtrace

Comment 2 Esa Varemo 2014-12-05 21:47:13 UTC
Created attachment 965238 [details]
File: environ

Comment 3 Miro Hrončok 2014-12-06 10:23:13 UTC
Does installing package numpy fix it?

Comment 4 Esa Varemo 2014-12-06 12:04:38 UTC
Yes, `yum install numpy` fixes this exact error, but now both plater and pronterface segfault when trying to start them (https://bugzilla.redhat.com/show_bug.cgi?id=1171353)

Comment 5 Miro Hrončok 2014-12-06 14:35:10 UTC
So let's fix bz1171353 first and then go back and fix this.

Comment 6 Miro Hrončok 2014-12-06 14:49:04 UTC
python-psutil is also missing from the requires.

Comment 7 Esa Varemo 2014-12-06 18:08:49 UTC
Yeah I also installed that but forgot about it since it didn't really affect the outcome/cause more issues

Comment 8 Fedora Update System 2014-12-29 11:29:50 UTC
printrun-2014.08.01-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/printrun-2014.08.01-1.fc21

Comment 9 Fedora Update System 2014-12-30 04:00:25 UTC
Package printrun-2014.08.01-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing printrun-2014.08.01-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-17728/printrun-2014.08.01-1.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-01-07 01:24:41 UTC
printrun-2014.08.01-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.