Bug 117134 - XKB Configuration Error Dialog on login to X
XKB Configuration Error Dialog on login to X
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 02:45 EST by Gregory Leblanc
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gregory Leblanc 2004-02-29 02:45:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.1.9

Description of problem:
The following XKB Configuration Error shows up whenever I log in to X.
 I've done nothing with xmodmap, or other X keyboard monkeying.

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The XFree86 Project, Inc
40300000
You are using XFree 4.3.0.
There are known problems with complex XKB configurations.
Try using simpler configuration or taking more fresh version of XFree
software.
If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb


Here's the output from the requested commands
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
$



$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
$





Version-Release number of selected component (if applicable):
XFree86-4.3.0-61

How reproducible:
Always

Steps to Reproduce:
1. install all packages from development
2. log in via GDM (I've not tested via startx)

    

Additional info:
Comment 1 scott white 2004-02-29 19:02:39 EST
i have the exact same problem. i have XFree86-4.3.0-61 on FC2 test1.
same error messages and same results from the requested commands. i'm
on an i686 as well

thanks 

scott
Comment 2 scott white 2004-02-29 20:15:18 EST
i'm not sure which, but one of these fixed the problem:

bonobo-devel-1.0.22-8
system-config-keyboard-1.2.1-1.1
nautilus-media-0.5.2-2
gnome-media-2.5.2-2
libgnome-devel-2.5.90-1
libgnomecanvas-devel-2.5.90-1
libgnomecanvas-2.5.90-1
libgnome-2.5.90-1
gnome-session-2.5.90-1
gconf-editor-2.5.4-1
XFree86-Mesa-libGLU-4.3.0-61
XFree86-font-utils-4.3.0-61
XFree86-tools-4.3.0-61
XFree86-75dpi-fonts-4.3.0-61
XFree86-xauth-4.3.0-61
XFree86-truetype-fonts-4.3.0-61
XFree86-base-fonts-4.3.0-61
XFree86-xdm-4.3.0-61
XFree86-Mesa-libGL-4.3.0-61
XFree86-100dpi-fonts-4.3.0-61
libgnomeui-devel-2.5.90-1
libgnomeui-2.5.90-1
#################################################
all these are available at:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

or one of the mirrors found on:
http://fedora.redhat.com/download/mirrors.html
Comment 3 Mike A. Harris 2004-02-29 23:58:24 EST
I can eliminate XFree86 from the above package list.  Nothing at all
has changed in XFree86 related to xkb that would cause the problem
described in this bug report.

I suspect that one of the GNOME packages above, or
system-config-keyboard were a likely cause of the problem.

Thanks for the update.

Closing as fixed in RAWHIDE by some unknown package.  ;o)
Comment 4 Gregory Leblanc 2004-03-04 00:52:50 EST
This error still shows up for me, in current rawhide.
Comment 5 James Laska 2004-04-14 10:43:53 EDT
Reopening, bug still active in xorg-x11-6.7.0-0.4

Upon login into gnome, I received the following window error message:

==========================================
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
==========================================

(~)> xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

(~)> gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 6 Alistair Willock 2004-04-14 22:14:17 EDT
I just performed an up2date on my FC2 test2 system (14/4/2004), and
encountered the exact scenario from Comment #5 above. My xprop and
gconftool replies are also identical to James'. Note that I hadn't
experienced the problem prior to this, and had previously done a full
package update on 12/4/2004. Therefore, it seems that one of the
package versions from the second update is the culprit.
 
I have all development packages installed for FC2, so my package list
is quite large, but here's the full listing of the packages I
installed on the 14th (all 135 of them):
 
anaconda-9.92-0.20040414005532.i386.rpm
anaconda-runtime-9.92-0.20040414005532.i386.rpm
balsa-2.0.17-1.i386.rpm
control-center-2.6.0.3-2.i386.rpm
cpp-3.3.3-7.i386.rpm
distcache-1.4.5-2.i386.rpm
distcache-devel-1.4.5-2.i386.rpm
eog-2.6.0-2.i386.rpm
esound-0.2.34-2.i386.rpm
esound-devel-0.2.34-2.i386.rpm
festival-1.4.2-21.i386.rpm
festival-devel-1.4.2-21.i386.rpm
gcc-3.3.3-7.i386.rpm
gcc-c++-3.3.3-7.i386.rpm
gcc-g77-3.3.3-7.i386.rpm
gcc-gnat-3.3.3-7.i386.rpm
gcc-java-3.3.3-7.i386.rpm
gcc-objc-3.3.3-7.i386.rpm
gedit-2.6.0-3.i386.rpm
gedit-devel-2.6.0-3.i386.rpm
ggv-2.6.0-2.i386.rpm
gimp-2.0.1-1.i386.rpm
gimp-devel-2.0.1-1.i386.rpm
gnome-mag-0.10.10-2.i386.rpm
gnome-mag-devel-0.10.10-2.i386.rpm
gnome-speech-0.3.2-2.i386.rpm
gnome-speech-devel-0.3.2-2.i386.rpm
gnome-system-monitor-2.6.0-2.i386.rpm
gnome-terminal-2.6.0-2.i386.rpm
gnome-themes-2.6.0-2.i386.rpm
gnome-user-docs-2.6.0.1-2.noarch.rpm
gnomemeeting-1.0.2-2.i386.rpm
gnopernicus-0.8.1-2.i386.rpm
gnucash-1.8.9-1.i386.rpm
gnucash-backend-postgres-1.8.9-1.i386.rpm
gok-0.10.0-2.i386.rpm
gthumb-2.3.2-2.i386.rpm
gtksourceview-1.0.0-2.i386.rpm
gtksourceview-devel-1.0.0-2.i386.rpm
kernel-2.6.5-1.322.i686.rpm
kernel-doc-2.6.5-1.322.i386.rpm
kernel-source-2.6.5-1.322.i386.rpm
krb5-devel-1.3.3-1.i386.rpm
krb5-libs-1.3.3-1.i386.rpm
krb5-server-1.3.3-1.i386.rpm
krb5-workstation-1.3.3-1.i386.rpm
libcroco-0.4.0-4.i386.rpm
libcroco-devel-0.4.0-4.i386.rpm
libf2c-3.3.3-7.i386.rpm
libgcc-3.3.3-7.i386.rpm
libgcj-3.3.3-7.i386.rpm
libgcj-devel-3.3.3-7.i386.rpm
libgnat-3.3.3-7.i386.rpm
libgnome-2.6.0-2.i386.rpm
libgnome-devel-2.6.0-2.i386.rpm
libgsf-1.8.2-3.i386.rpm
libgsf-devel-1.8.2-3.i386.rpm
libgtop2-2.5.2-2.i386.rpm
libgtop2-devel-2.5.2-2.i386.rpm
libobjc-3.3.3-7.i386.rpm
librsvg2-2.6.4-2.i386.rpm
librsvg2-devel-2.6.4-2.i386.rpm
libstdc++-3.3.3-7.i386.rpm
libstdc++-devel-3.3.3-7.i386.rpm
libtool-1.5.6-1.i386.rpm
libtool-libs-1.5.6-1.i386.rpm
lm_sensors-2.8.6-1.i386.rpm
lm_sensors-devel-2.8.6-1.i386.rpm
openh323-1.13.4-2.i386.rpm
openh323-devel-1.13.4-2.i386.rpm
pam-0.77-39.i386.rpm
pam-devel-0.77-39.i386.rpm
parted-1.6.9-2.i386.rpm
parted-devel-1.6.9-2.i386.rpm
policy-1.11.2-1.noarch.rpm
policy-sources-1.11.2-1.noarch.rpm
policycoreutils-1.10-2.i386.rpm
popt-1.9.1-0.2.i386.rpm
rhpl-0.139-1.i386.rpm
rpm-4.3.1-0.2.i386.rpm
rpm-build-4.3.1-0.2.i386.rpm
rpm-devel-4.3.1-0.2.i386.rpm
rpm-python-4.3.1-0.2.i386.rpm
rpmdb-fedora-1.91-0.20040414.i386.rpm
samba-3.0.3-2.pre2.i386.rpm
samba-client-3.0.3-2.pre2.i386.rpm
samba-common-3.0.3-2.pre2.i386.rpm
samba-swat-3.0.3-2.pre2.i386.rpm
setools-1.2.1-7.i386.rpm
setools-gui-1.2.1-7.i386.rpm
setuptool-1.14-1.i386.rpm
startup-notification-0.6-2.i386.rpm
startup-notification-devel-0.6-2.i386.rpm
sysstat-5.0.1-2.i386.rpm
system-config-display-1.0.13-1.noarch.rpm
system-config-samba-1.2.9-2.noarch.rpm
system-config-securitylevel-1.3.10-5.i386.rpm
system-config-securitylevel-tui-1.3.10-5.i386.rpm
system-config-services-0.8.8-8.noarch.rpm
system-config-soundcard-1.2.7-4.noarch.rpm
system-config-users-1.2.11-5.noarch.rpm
udev-023-2.i386.rpm
up2date-4.3.16-1.i386.rpm
up2date-gnome-4.3.16-1.i386.rpm
w3m-0.5-2.i386.rpm
xorg-x11-6.7.0-0.4.i386.rpm
xorg-x11-100dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-75dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8859-14-100dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8859-14-75dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8859-15-100dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8onts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8859-9-100dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-ISO8859-9-75dpi-fonts-6.7.0-0.4.i386.rpm
xorg-x11-Mesa-libGL-6.7.0-0.4.i386.rpm
xorg-x11-Mesa-libGLU-6.7.0-0.4.i386.rpm
xorg-x11-Xnest-6.7.0-0.4.i386.rpm
xorg-x11-Xvfb-6.7.0-0.4.i386.rpm
xorg-x11-base-fonts-6.7.0-0.4.i386.rpm
xorg-x11-cyrillic-fonts-6.7.0-0.4.i386.rpm
xorg-x11-devel-6.7.0-0.4.i386.rpm
xorg-x11-doc-6.7.0-0.4.i386.rpm
xorg-x11-font-utils-6.7.0-0.4.i386.rpm
xorg-x11-libs-6.7.0-0.4.i386.rpm
xorg-x11-libs-data-6.7.0-0.4.i386.rpm
xorg-x11-sdk-6.7.0-0.4.i386.rpm
xorg-x11-syriac-fonts-6.7.0-0.4.i386.rpm
xorg-x11-tools-6.7.0-0.4.i386.rpm
xorg-x11-truetype-fonts-6.7.0-0.4.i386.rpm
xorg-x11-twm-6.7.0-0.4.i386.rpm
xorg-x11-xauth-6.7.0-0.4.i386.rpm
xorg-x11-xdm-6.7.0-0.4.i386.rpm
xorg-x11-xfs-6.7.0-0.4.i386.rpm
 
Hopefully, we'll be able to cross-reference against the package deltas
of others who encounter the problem to narrow things down.
Comment 7 Ken Schar 2004-04-18 09:11:48 EDT
 xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

 gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []

No new info here - can we run this with the debug packages to get more
info for you?

Thanks!
  Ken
Comment 8 Mark Westerman 2004-04-19 09:07:46 EDT
I had the same problem also after upgrading to all the updates
for test 2 release. I have found a work around for now
                                                                     
          
Create the following sysbolic link in the following
directory
/usr/X11R6/lib/X11/xkb/rules
                                                                     
          
                                                                     
          
xfree86-it.lst -> xorg-it.lst
xfree86.lst    -> xorg.lst
xfree86.xml    -> xorg.xml

Mark
Comment 9 Jeremy Phillips 2004-04-24 15:49:25 EDT
This work around works for me, however, it only works for the root user.  
When I log in as a non-privleged, I still get the error, my task bar
is missing, and I have no desktop icons.  All of this came about after
running up2date on a freshly installed Fedora Core 2 Test 2 box.
Comment 10 Miloslav Trmac 2004-04-26 11:00:51 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 11 Paul Morgan 2004-05-24 14:13:25 EDT
I had the same problem on fc2 final (running ltsp). I used Mark
Westerman's workaround:

Create the following sysbolic link in the following directory
/usr/X11R6/lib/X11/xkb/rules
                                                                     
xfree86.lst    -> xorg.lst
xfree86.xml    -> xorg.xml
Comment 12 Red Hat Bugzilla 2006-02-21 14:01:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.