Bug 117138 - 20040228 fc-devel: anaconda traceback "error: match tag mismatch"
20040228 fc-devel: anaconda traceback "error: match tag mismatch"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-29 04:14 EST by Barry K. Nathan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 01:05:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump: NFS install, Minimal package set, ext3 root fs (615.46 KB, text/plain)
2004-02-29 04:17 EST, Barry K. Nathan
no flags Details

  None (edit)
Description Barry K. Nathan 2004-02-29 04:14:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
I'm trying to install FC devel onto one of my machines. After I click
"next" on the "installation will start once you click Next" screen
(after you select the packages, etc.) it format the root partition (I
have no other partitions to format in my case), then produces this
traceback with the phrase "error: match tag mismatch".

(I will attach an anacdump.txt file to this bug)

Version-Release number of selected component (if applicable):
anaconda-9.91-0.20040226192747, rpmdb-fedora-1.90-0.20040228

How reproducible:
Always

Steps to Reproduce:
1. Boot from boot.iso. Optionally specify other filesystems or vnc
(those options made no difference for me either way).
2. Begin installation over HTTP or NFS. (Other methods may work, but I
didn't test those.)
3. Choose a server install. (Other types of installs may work, but I
didn't test those.) Package selection doesn't seem to matter as far as
I can tell, but "Minimal" is what I used most during testing. (I did
not try "Everything" however.)
    

Actual Results:  Formats filesystem, then produces traceback

Expected Results:  Formats filesystem and proceeds uneventfully with
installation

Additional info:

With the previous day's devel (same version of anaconda, but
rpmdb-fedora-1.90-0.20040227) I do not experience this bug.

If this happens to be due to a corrupted or inconsistent installation
source, or anything of that sort, then a more user-friendly error
message would be really nice.
Comment 1 Barry K. Nathan 2004-02-29 04:17:11 EST
Created attachment 98130 [details]
anacdump: NFS install, Minimal package set, ext3 root fs

I have two other anacdumps (one for HTTP install, onto an XFS filesystem, with
a customized package set; the other is HTTP install, onto an XFS filesystem,
with Minimal package set). I can attach one or both if you're interested.
Comment 2 Barry K. Nathan 2004-03-02 03:15:04 EST
By the way, I forgot to mention, boot.iso for 20040227 and 20040228
was bit-for-bit identical (at least on my downloads). Just in case
this matters...
Comment 3 Jeremy Katz 2004-04-15 01:05:40 EDT
This is usually random tree horkage.  If you're not seeing with
current trees, closing.
Comment 4 Barry K. Nathan 2004-04-15 01:19:33 EDT
I haven't tried current trees; my employer is considering deploying
Red Hat Enterprise Linux and I recently noticed that I somehow have 2
RHEL subscriptions that will expire at the end of the month, so I've
been playing with that instead. However, I think this problem
disappeared with the trees from shortly after I filed this bug, so
I'll leave the bug closed.

(It would be nice if the error message could be nicer/easier to
understand, but oh well.)

Note You need to log in before you can comment on or make changes to this bug.