Bug 117141 - All files in info directory are compressed implicitly
All files in info directory are compressed implicitly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 04:29 EST by Torsten Bronger
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-29 17:45:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torsten Bronger 2004-02-29 04:29:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
All files in the /usr/share/info directory (or %{_infodir}/) are
compressed with gzip by rpmbuild.  This is bad behaviour since there
are images (PNGs) too in this directory, and they mustn't be compressed.

Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Always

Steps to Reproduce:
1. My spec files say e.g.
   %{_infodir}/algaas.png
   %{_infodir}/equation.png
   %{_infodir}/tbtrafos.png
   %{_infodir}/unit.png
2. Call rpmbuild
3. rpmbuild simply doesn't files these files since they now have the
extension ".gz".


Actual Results:  All files in info/ are compressed.

Expected Results:  Only files in info/ with a typical info filename
extension should be compressed, or alternatively, all files with a
typical image file extension sould be excluded from the compression
process.
Comment 1 Jeff Johnson 2004-02-29 17:45:08 EST
%{_infodir} is used for inof(1) files, where compression
is expected and useful.

No idea why *.png files are there.

Reconfigure rpm to not compress if you want, %__os_install_post
appends a set of build policy scripts (see /usr/lib/rpm/brp-*),
to end of %install, and one of those scripts is implementing
the policy "Everything in /usr/share/info/should be compressed."
Comment 2 Torsten Bronger 2004-02-29 18:07:06 EST
Latest releases of makeinfo allow the inclusion of PNG files in Info
documentation.  They are stored in the same directory as the info
files, so perhaps the default behaviour (in brp-compress as far as I
can see) should be modified.

But be that as it may, thank you very much for the explanation.

Note You need to log in before you can comment on or make changes to this bug.