This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1171436 - qemu fails to connect to gluster if run as a regular user, affects libvirt
qemu fails to connect to gluster if run as a regular user, affects libvirt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glusterfs (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-06 20:02 EST by Cole Robinson
Modified: 2014-12-08 14:27 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 14:27:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2014-12-06 20:02:52 EST
$ qemu-system-x86_64 -nographic -cdrom gluster://192.168.124.100/gv0/boot-with-serial.iso

[2014-12-07 00:56:30.280951] E [rpc-clnt.c:369:saved_frames_unwind] (-->/lib64/libgfrpc.so.0(rpc_clnt_notify+0x48) [0x7f59dae77918] (-->/lib64/libgfrpc.so.0(rpc_clnt_connection_cleanup+0xb7) [0x7f59dae75be7] (-->/lib64/libgfrpc.so.0(saved_frames_destroy+0xe) [0x7f59dae75b0e]))) 0-gfapi: forced unwinding frame type(GlusterFS Handshake) op(GETSPEC(2)) called at 2014-12-07 00:56:30.280302 (xid=0x1)
[2014-12-07 00:56:30.281051] E [glfs-mgmt.c:586:mgmt_getspec_cbk] 0-glfs-mgmt: failed to fetch volume file (key:gv0)
[2014-12-07 00:56:30.281099] E [glfs-mgmt.c:680:mgmt_rpc_notify] 0-glfs-mgmt: failed to connect with remote-host: 192.168.124.100 (No data available)
qemu-system-x86_64: -cdrom gluster://192.168.124.100/gv0/boot-with-serial.iso: could not open disk image gluster://192.168.124.100/gv0/boot-with-serial.iso: Gluster connection failed for server=192.168.124.100 port=0 volume=gv0 image=boot-with-serial.iso transport=tcp: Transport endpoint is not connected

But if I run with sudo, it works:

$ sudo qemu-system-x86_64 -nographic -cdrom gluster://192.168.124.100/gv0/boot-with-serial.iso
Linux version 2.6.18-92.el5 (brewbuilder@ls20-bc2-13.build.redhat.com) (gcc version 4.1.2 20071124 (Red Hat 4.1.2-41)) #1 SMP Tue Apr 29 13:16:15 EDT 2008
Command line: initrd=initrd.img console=tty0 console=ttyS0,115200n8 BOOT_IMAGE=vmlinuz
...

This also affects VMs launched with libvirt as well, since they are launched with reduced privileges. I don't know if this is a regression or not since it's the first time I'm running with gluster + qemu.

Host and server running:
$ $ rpm -q qemu-system-x86 libvirt-daemon glusterfs
qemu-system-x86-2.1.2-6.fc21.x86_64
libvirt-daemon-1.2.9.1-2.fc21.x86_64
glusterfs-3.5.3-1.fc21.x86_64
Comment 1 Niels de Vos 2014-12-07 06:23:35 EST
I'm temped to close this as NOTABUG, assuming you have missed this step:
- http://www.gluster.org/community/documentation/index.php/Libgfapi_with_qemu_libvirt#Tuning_glusterfsd_to_accept_requests_from_QEMU

Please confirm. Thanks!
Comment 2 Niels de Vos 2014-12-07 06:25:20 EST
(In reply to Niels de Vos from comment #1)
> I'm temped to close this as NOTABUG, assuming you have missed this step:
> -
> http://www.gluster.org/community/documentation/index.php/
> Libgfapi_with_qemu_libvirt#Tuning_glusterfsd_to_accept_requests_from_QEMU

Oh, and also the rpc-auth-allow-insecure option mentioned in the paragraph just before that.
Comment 3 Cole Robinson 2014-12-08 14:27:11 EST
Indeed that fixed it. Sorry, I tried googling but somehow missed bug 1057292

Note You need to log in before you can comment on or make changes to this bug.