Bug 117149 - version 2.8.3-4 does not install libsensors correctly
version 2.8.3-4 does not install libsensors correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 08:33 EST by Dimitris
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 04:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2004-02-29 08:33:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
lm_sensors version 2.8.3-4 does not seem to
install libsensors or one of its components
since all temperatures can not be read.

This is ticket number 1591 at lm_sensors support:
http://secure.netroedge.com/~lm78/readticket.cgi?ticket=1591

2.8.4 is out and i was told the RPM should
be updated to that newer version.


Version-Release number of selected component (if applicable):
lm_sensors-2.8.3-4

How reproducible:
Always

Steps to Reproduce:
1. install lm_sensors
2. run detect-sensors
3. run sensors -c
4. run sensors to see results

Actual Results:  temperatures can't be read

Expected Results:  temperatures should be read

Additional info:

Please upgrade to version 2.8.4
Comment 1 Phil Knirsch 2004-03-05 09:36:04 EST
Who from which support told you this is a libsensors/sensors mismatch?
I think it's highly unlikely as lm_sensors updates both, sensors and
libsensors at the same time, so a mismatch is nearly impossible.

I'll update to 2.8.5 as soon as that is released, hopefully that will
fix the problem you're seeing.

Read ya, Phil
Comment 2 Dimitris 2004-03-05 13:28:04 EST
I posted a support request ticket at the lm_sensors website:
http://secure.netroedge.com/~lm78/readticket.cgi?ticket=1591

I am not sure who replied, but it must be one of the admins.

Maybe this particular rpm was broken and didn't update both
sensors and libsensors?

Anyway, i'll wait for your 2.8.5 release to test.
Comment 3 Phil Knirsch 2004-03-08 11:38:18 EST
OK. As i said, the lm_sensors package updates both sensors and libsensors.

Are you using the lm_sensors initscript by any chance? Because with
the latest 2.6 kernel that doesn't work anymore. I just updated that
script to work correctly again.

If you like you can give lm_sensors-2.8.3-5 or later a shot which
should be available in the next few days.

Read ya, Phil
Comment 4 Dimitris 2004-03-08 15:59:06 EST
No i'm not using the initscript of lm_sensors, and i'm at the
latest 2.4 kernel.

I'll try the newer version when it comes out.
Comment 5 Dimitris 2004-04-05 04:35:19 EDT
I've been told that lm_sensors 2.8.5 has the fix to
make lm_sensors work again on my system, i've checked
the changelog and it seems the it87 driver for my
system has had many updates.

I'll try the 2.8.3-5 just in case though.
Comment 6 Dimitris 2004-04-05 04:44:57 EDT
I updated to 2.8.3-5 and i still can't get any temperature readings,
as stated above i get these errors:

ERROR: Can´t get TEMP1 data!
ERROR: Can´t get TEMP2 data!
ERROR: Can´t get TEMP3 data!

Please update lm_sensors to 2.8.5.
Comment 7 Phil Knirsch 2004-04-13 10:52:33 EDT
A new lm_sensors 2.8.6 package will be built today.

Please give that one a shot.

Thanks,

Read ya, Phil
Comment 8 Dimitris 2004-04-14 00:53:26 EDT
Could you please tell me where to download 2.8.6 from? i've been
trying to find the file without success in the
http://download.fedora.redhat.com/pub/fedora/linux/core/ file
structure, but all i can find is 2.8.3 or older versions.
Comment 9 Phil Knirsch 2004-04-14 05:05:41 EDT
It should appear in the next couple of days here:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

Read ya, Phil
Comment 10 Dimitris 2004-04-15 01:05:27 EDT
Just tested version 2.8.6 and i'm having the same problem. I think
this is related to the recent changes in the it87 driver, which
probably broke some sensors. I've tried to get help from lm_sensors
people but they are avoiding the issues by giving the typical excuses.

Anyway, i dont think this is a fedora/redhat problem.
Comment 11 Dimitris 2004-04-16 03:35:43 EDT
After long hours of debuging and testing, i've come up with the same
initial results.

the rpm package does not update the sensor modules.

under /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sensors the
sensors are the old/original 2.6.5.

the rpm package does not include the new versions of the sensors
and since the old versions don't support the new libsensor interface,
they break compatibility.
Comment 12 Dimitris 2004-04-16 04:04:01 EDT
hmm after some careful discussion with Jean Delvare from lm_sensors
mailing list, we've realised that the lm_sensors package only updates
the user-space tools and not the kernel modules.

thats... erm well, sort of pointless, since every time the user space
tools are updated, the kernel modules must be updated too! otherwise
this is what happens, they can't communicate correctly.

in other words, only a kernel update will solve this problem, and i
also think that the lm_sensors package should only be updated when
a new kernel comes out, in order to avoid breaking things (so both
kernel and user-space modules are the same version).

Comment 13 Phil Knirsch 2004-04-16 04:56:49 EDT
Unfortunately we have a strict rule that no userland tool may build
and install any kernel modules.

So if you want to have the latest drivers for lm_sensors then you also
need to update to the latest kernel (one of the 2.6.5 series),
otherwise you certainly won't have the latest drivers.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.