Bug 117151 - Gedit hangs on long lines
Gedit hangs on long lines
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 10:47 EST by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 07:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File that causes hangs of gedit on my system (24.12 KB, application/octet-stream)
2004-02-29 10:47 EST, Leonard den Ottolander
no flags Details

  None (edit)
Description Leonard den Ottolander 2004-02-29 10:47:05 EST
Description of problem:

When I edit the attached file gedit stops responding after I scroll
the page down and back up again. This might have something to do with
the length of the lines.

Note that my system locale is en_US.ISO-8859-15.


Version-Release number of selected component (if applicable):

gedit-2.4.0-3


How reproducible:

(Set system locale to en_US.ISO-8859-15 (not sure if this is necessary).)
Unzip and open the attached file and open it with gedit.
Scroll down and back up.
Gedit hangs (it can be forced to quit though).
Comment 1 Leonard den Ottolander 2004-02-29 10:47:54 EST
Created attachment 98139 [details]
File that causes hangs of gedit on my system
Comment 2 Leonard den Ottolander 2004-02-29 11:06:20 EST
Changing subject.

Indeed the long lines seem to be the problem (I stripped out everthing
but the "component" line with kedit and also see the hang on the
resulting file).
Comment 3 Bart Martens 2004-02-29 11:44:53 EST
The problem is tracked upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=134682

Note You need to log in before you can comment on or make changes to this bug.