This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117155 - HTTP install reports errors late and without usable information
HTTP install reports errors late and without usable information
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC4
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 13:12 EST by Fridjon Gudjohnsen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fridjon Gudjohnsen 2004-02-29 13:12:45 EST
When installation from HTTP is attempted the installation program 
does not check that the entered path to the fedora directory is a 
directory that can be used for the installation. 

After entering the details of the HTTP server to use the installation 
program proceeds to collect info on mouse/keyboard/monitor/partitions 
etc. It is only at the end of this information collection that the 
user is informed that the directory entered does not contain package 
information required to continue. At that point the user has no way 
of correcting the entered path, she can only retry the reading of 
package information (which will most likely result in the same error).

This is especially bad because the installation directory that should 
be entered is by no means obvious. In my installation I mounted the 
ISOs on another linux box and symlinked them to a directory on 
Apache. The structure visible from the webserver has a root direcory 
named /fedora and under it are separate directories for each disc 
(i.e. /fedora/disc1  /fedora/disc2   /fedora/disc3  /fedora/disc4). 
When I enter the IP-address of the webserver in the first text field 
and "/fedora/" in the second field I get this error. When I 
enter "/fedora/disc1/" the installation seems to proceed normally.
Comment 1 Jeremy Katz 2004-10-18 10:39:15 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.