This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 11716 - RedHat 6.2 and 6.1 installation on Alpha does not detect onboard Qlogic ISP1020 Scsi controller
RedHat 6.2 and 6.1 installation on Alpha does not detect onboard Qlogic ISP10...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-28 12:51 EDT by mike.radomski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 14:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike.radomski 2000-05-28 12:51:36 EDT
I have a Alpha PWS 600au with an onboard Qlogic isp1020 controller and a
pci Qlogic isp1020 controller.  The redhat version 6.1 and 6.2 boot images
do not detect the onboard controller.  Previously I had redhat 6.0
installed on the system.  I installed it using the boot images found at
ftp://ftp.digital.com/pub/DEC/Linux-Alpha/Images.  The 2.2.12 kernel on
that disk is able to recognize both controllers.  I am able to install
redhat 6.2 from that disk.  However when rebooting after the  install, the
stock kernel (2.2.14-6.0) that comes with redhat 6.2 does not boot.
Actually it boots but cannot mount the root fs because it has not
recognized the onboard scsi card.

This all occurs even if I remove the pci qlogic controller.

I did not see am updated boot.img from ftp://updates.redhat.com

Thank you..
Comment 1 mike.radomski 2000-06-01 09:22:19 EDT
I have tried the RawHide kernel update 2.2.14-100 and it still does not detect 
the onboard scsi adaptor.  I upgraded to the 2.2.15 kernel.  It detected both 
scsi adaptors but I then got a keyboard timeout [2] error.  But the scsi 
adaptors were detected just fine.  Is there a fix the the keyboard timeout [2] 
problem.  I searched the newsgroups and found a few people with that problem 
but no answer to it.
Comment 2 Brock Organ 2000-06-23 12:03:36 EDT
I am unable to reproduce this problem in our test lab using 6.2 ...

% lspci ; lspci -n
01:06.0 SCSI storage controller: Q Logic ISP1020 (rev 06)                       
01:06.0 Class 0100: 1077:1020 (rev 06)                                           

% dmesg
...
qlogicisp : new isp1020 revision ID (6)                                         
DC390: 0 adapters found                                                         
scsi0 : QLogic ISP1020 SCSI on PCI bus 01 device 30 irq 47 I/O base 0x100009800 
scsi : 1 host.                                                                  
Vendor: DEC       Model: RZ2DC-KA (C) DEC  Rev: 5520                            
Type:   Direct-Access                      ANSI SCSI revision: 02               
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0                         
scsi : detected 1 SCSI disk total.                                              
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]   
Partition check:                                                                
sda: sda1 sda2             
...
Comment 3 mike.radomski 2000-07-10 09:06:24 EDT
I just upgraded the the 2.2.16-3 kernel and both cards show up fine.

Note You need to log in before you can comment on or make changes to this bug.