Bug 117170 - ggv is too slow
ggv is too slow
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ggv (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 22:39 EST by Tethys
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 20:45:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2004-02-29 22:39:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
FC1 no longer ships with a sane PostScript viewer. With the upgrade
from RH9 to FC1, gv disappeared, to be replaced with ggv. While I
agree with, and fully support the goal of having a consistent user
interface across apps, it shouldn't be at the expense of usability.
Where gv used to launch in under a second, ggv takes over 10 seconds
from cold, and even from cache takes 5s. That's just not acceptable
performance, and severely limits its usefulness. I don't know if this
is just a GTK-2 thing -- previous versions of ggv (e.g., 1.0.1 from
RH7.2) launched much quicker. Other GTK-2 apps are a bit sluggish
perhaps, but not to the same extent as ggv. Perhaps the following
comparison may shed some light on the problem:

   lazarus:~% cat /etc/redhat-release 
   Red Hat Linux release 7.2 (Enigma)
   lazarus:~% rpm -q ggv
   ggv-1.0.1-4
   lazarus:~% ldd /usr/bin/ggv | wc -l
        22


   leto:~% cat /etc/redhat-release 
   Fedora Core release 1 (Yarrow)
   leto:~% rpm -q ggv
   ggv-2.4.0.1-1
   leto:~% ldd /usr/bin/ggv | wc -l
        53

Whatever the reason, though, I don't particularly care. Please either
fix it, or revert to using gv until ggv can be brought up to speed.

Version-Release number of selected component (if applicable):
ggv-2.4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. Launch ggv
2. Wait... Go grab a drink
3. Wait some more. You get the idea...
    

Additional info:
Comment 1 Robert Vojta 2004-03-02 08:12:22 EST
Interesting, my laptop is very slow - Celeron 700MHz with 192MB RAM
and ggv is starting under 2 seconds and under 1 second from the cache.

[My system is FC1 without updates, same ggv as yours]

Comment 2 Jonathan Blandford 2004-03-03 11:43:51 EST
I have no obvious speed problems w/ GGV.  Is anything else slow on
your system?  Regardless of which, I'm not going to remove ggv for gv.  
Comment 3 Tethys 2004-03-03 17:06:58 EST
:-) No, I wasn't expecting you to remove ggv. But I would appreciate
looking into what's causing it to be *so* much slower than plain gv.
Probably not the sole cause of the problem, but does it really need
to be linked against libesd or libaudiofile, for example?

I may not have the fastest machine in the world (a PIII/550), but
other apps are generally OK. It's just ggv that's bordering on
unusably slow.
Comment 4 Jonathan Blandford 2004-03-03 17:16:10 EST
Yes, it does need to link against those for a number of reasons.

I don't know why it's slow.  it's not particularly slow for me.  Are
you loading it with a file?
Comment 5 Jonathan Blandford 2004-03-04 20:10:32 EST
Okay - I think I've found the problem.  Looks like GGV is being too
agressive w/ its recently-used files.  If you move ~/.recently-used
out of the way, does it start much faster?
Comment 6 Tethys 2004-03-04 20:19:40 EST
Yep, that certainly seems to help.
Comment 7 Jonathan Blandford 2004-03-04 20:33:30 EST
Cool.  Submitted a patch upstream.  We should get this fixed by FC2.
Comment 8 Jonathan Blandford 2004-03-04 20:45:34 EST
http://bugzilla.gnome.org/show_bug.cgi?id=136238

Note You need to log in before you can comment on or make changes to this bug.