Bug 117171 - kernel 2.6.3 (and 2.6.2) kernel panik with ipsec (interrupt not syncing)
kernel 2.6.3 (and 2.6.2) kernel panik with ipsec (interrupt not syncing)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-29 23:26 EST by Jost Diederichs
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-09 09:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Diederichs 2004-02-29 23:26:56 EST
Description of problem:
Heavy traffic through ipsec tunnel (100 or more kb/sec) will cause
kernel panic after about 5 to 10 seconds. 

Version-Release number of selected component (if applicable):
so far I have tested almost all fedora development kernels from
version 2.6.3-1.90 up to version 2.6.3-1.116

How reproducible:
Happens every time. Either heavy traffic through the tunnel or a
combination of some traffic through the tunnel and heavy traffic to
the internet. 
I have tested this now on two different machines ( one AMD K6-2 and
one Intel PIII on Intel motherboard) with the same results. 
I have also used both, the freeswan userland tools and the racoon
tools to setup the tunnel, in both cases using the kernel's built in
ipsec functionality. 

The kernel debug output is long and scrolls off my screen. I will
obtain a null modem cable and try to capture it to an external console. 

Here is what I managed to capture from what is visible on the console: 
EIP is at des_small_fips_decrypt
[...]
 Kernel panik: Fatal exception in interrupt
In interrupt handler - not syncing
Comment 1 Christopher Johnson 2004-03-06 10:34:12 EST
Is bug 116494 a duplicate of this?
Comment 2 Jost Diederichs 2004-03-06 23:33:04 EST
It probably is, sorry about that. 

In addition, this bug appears to be fixed in kernel-2.6.3-2.1.238. I
haven't been able to reproduce it. 

Note You need to log in before you can comment on or make changes to this bug.