This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 117186 - Open office has lost read access to odbc DB
Open office has lost read access to odbc DB
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 117190 (view as bug list)
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-01 08:14 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 07:45:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-03-01 08:14:16 EST
Description of problem:
When I installed FC2 test1 odbc access to Postgresql worked properly
ie: write access. Now for some reason only read access is allowed.

This seemed to happen after I did a query via odbc
Comment 1 Need Real Name 2004-03-01 08:53:48 EST
Further info

I have tested the Database/odbc driver with excel/access and
everything works fine.
Comment 2 Dan Williams 2004-03-01 11:09:00 EST
*** Bug 117190 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2004-10-28 08:18:27 EDT
caolanm->mike@bristolreccc.co.uk: 
What's your unixODBC rpm version ? Can you try with a unixODBC >= 2.2.8 ?
Comment 4 Caolan McNamara 2004-12-09 07:44:51 EST
openoffice.org-1.1.2-11.5.fc3
unixODBC-2.2.10-1
postgresql-7.4.6-1.FC3.1

> su - postgres
> createuser
Enter name of user to add: cmc
Shall the new user be allowed to create databases? (y/n) y
Shall the new user be allowed to create more new users? (y/n) y
CREATE USER
> exit
> su - cmc
> createdb
CREATE DATABASE
> su 
cat > /etc/odbc.ini
[PostgreSQL-test]
Description = Postgres database test
ReadOnly = 0
Servername = localhost
Database = cmc
Port = 5432
Driver = PostgreSQL
Protocol = 7.4.6
UserName = cmc
Password =
^D
> exit
> oowriter &
tools->data sources
new data source, database type ODBC, select PostgreSQL-test
successfully add a table with some random column types
can view and edit database
create a simple query, can run it and can still edit afterwards
exit oowriter, restart, still ok

I suspect that it might have been a problem with unixODBC, I can't
reproduce a similiar problem on FC-3. Though if theres another way to
reproduce this, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.