Bug 1171907 - [RFE] Discovery manual provisioning via ISO (USB)
Summary: [RFE] Discovery manual provisioning via ISO (USB)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin
Version: 6.0.6
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-08 22:13 UTC by Chris Roberts
Modified: 2019-09-26 17:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:12:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
discovered host can be seen from webUI (31.77 KB, image/png)
2016-04-05 07:46 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Chris Roberts 2014-12-08 22:13:54 UTC
Description of problem:

https://access.redhat.com/solutions/1203423
is the method we currently use.  The method is the foreman_bootdisk plugin method included with Satellite 6.  This method generates a hybrid iso image that can be written to CD or usb flash.  Booting off this image uses ipxe from the images included in the ipxe-bootimgs rpm that comes with Satellite 6.  It is this ipxe kernel that does not include support for the BCM5716 network adapter (pci id 14e4:163b) thus the install fails.

How reproducible:

https://access.redhat.com/solutions/1203423
is the method we currently use.  The method is the foreman_bootdisk plugin method included with Satellite 6.  This method generates a hybrid iso image that can be written to CD or usb flash.  Booting off this image uses ipxe from the images included in the ipxe-bootimgs rpm that comes with Satellite 6.  It is this ipxe kernel that does not include support for the BCM5716 network adapter (pci id 14e4:163b) thus the install fails.

Actual results:
drivers are not loaded correctly in the ipxe-bootimgs

Expected results:
to include the drivers in the ipxe bootimg

Additional info:

I have been looking at the foreman discovery images:
foreman-discovery-image-6.5-20140620.2.el6sat.noarch

With the installer extracted files:
/var/lib/tftpboot/boot/foreman-discovery-image-latest.el6.iso-img
/var/lib/tftpboot/boot/foreman-discovery-image-latest.el6.iso-vmlinuz
BCM5716 support is included.

Maybe there is a way to make a bootable usb drive from these that can be used to provision a machine.  Normally they are used as an image downloaded via pxe, but the stock method uses ipxe.  I'm thinking that instead burn them to flash and boot it directly.  I'm having trouble deciphering what the kernel parameters in isolinux.cfg would need to be though.

Comment 1 RHEL Product and Program Management 2014-12-08 22:23:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Lukas Zapletal 2015-04-28 08:32:19 UTC
Hello,

unfortunately iPXE is not compatible with this hardware and Discovery in Satellite 6.0/6.1 cannot be used for manual provisioning. But we are working on a prototype of adding manual provisioning (with or without DHCP) via Discovery image which supports all the hardware which is supported by RHEL 7 (I assume the network card of the Dell system is fully supported there).

For more details:

http://projects.theforeman.org/projects/katello/wiki/Bootdisk#Discovery

This should solve your problem. I re-scheduled this bug for 6.2 and we will evaluate this if the feature is implemented upstream.

Comment 4 Lukas Zapletal 2015-04-29 13:30:59 UTC
To inform you, this feature has green light. The prototype discussion recording is available here: https://www.youtube.com/watch?v=Qsd6trn7ohU

Upstream tracking feature is here:

http://projects.theforeman.org/issues/10294

I am renaming this BZ, we will implement the Discovery method to provision on all hardware which is supported by RHEL 7.

Comment 6 Bryan Kearney 2015-08-25 18:32:45 UTC
Upstream bug component is Discovery Plugin

Comment 7 Corey Welton 2016-01-26 18:23:20 UTC
Sachin,

This should be in upstream builds by now; when you take a look at PXEless in later composes, please revisit this.

Comment 9 Sachin Ghai 2016-04-04 11:59:36 UTC
Verified this bz with satellite 6.2 snap6.

we can perform discovery with and without dhcp. PXELess discovery can be performed in case we don't have dhcp server available for provisioning.

Boot the host via discovery ISO and manually pass the IPaddress/gateway and configure your network.

ISO can be found with foreman-discovery-image rpm:

/usr/share/foreman-discovery-image/foreman-discovery-image-3.1.1-1.iso

Comment 11 Sachin Ghai 2016-04-04 17:20:43 UTC
Please consider steps defined in comment10 as an example because subnet and iso image version may vary.

Comment 12 Sachin Ghai 2016-04-05 07:46:11 UTC
Created attachment 1143681 [details]
discovered host can be seen from webUI

Comment 13 Sachin Ghai 2016-04-05 07:46:57 UTC
Moving this to verified.

Comment 15 errata-xmlrpc 2016-07-27 09:12:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.