Bug 1172043 - Broken link to documentation PDFs in RHEVM welcome page.
Summary: Broken link to documentation PDFs in RHEVM welcome page.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-doc
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Greg Sheremeta
QA Contact: Pavel Novotny
URL:
Whiteboard: ux
Depends On: 1174051
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-12-09 09:46 UTC by Nisim Simsolo
Modified: 2015-02-16 13:35 UTC (History)
13 users (show)

Fixed In Version: rhevm-doc-3.5.0-4.el6eng.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
rhevm-3.5.0-0.23.beta.el6ev.noarch
Last Closed: 2015-02-16 13:35:39 UTC
oVirt Team: ---


Attachments (Terms of Use)
welcome page and error 404 screenshot (519.45 KB, application/vnd.oasis.opendocument.graphics)
2014-12-09 09:47 UTC, Nisim Simsolo
no flags Details

Description Nisim Simsolo 2014-12-09 09:46:48 UTC
Description of problem:
Browsing RHEVM welcome page and trying to open PDF (and 1 of the http links) of the next documentation failed with HTTP error 404:
Administration guide - PDF
Installation guide - PDF
Technical guide - PDf
User Guide - PDF
Manager release notes - PDF and HTTP link

Version-Release number of selected component (if applicable):
VT13.1

How reproducible:
Constantly

Steps to Reproduce:
1.Open engine welcome page (mine engine for example: http://10.35.162.34/ovirt-engine/)
2. Under "Documentation" column, try to open one of the PDFs

Actual results:
PDF should open after clicking on it.

Expected results:
"404 - Page not found" error message appears

Additional info:
Screenshot attached

Comment 1 Nisim Simsolo 2014-12-09 09:47:56 UTC
Created attachment 966165 [details]
welcome page and error 404 screenshot

Comment 2 Einav Cohen 2014-12-09 21:43:24 UTC
@Greg - known? shouldn't we have "stub" PDFs for PDFs that are currently missing (if any)?

[not sure if Component should be "rhevm-branding-rhev", "rhevm-doc" or something else - please change accordingly, if needed]

Comment 3 Greg Sheremeta 2014-12-10 14:02:58 UTC
Manager Release Notes is not done, so those 404s are expected.

The PDFs should be there. I'll fix.

Comment 4 Greg Sheremeta 2014-12-15 02:24:51 UTC
Fixed, but can't build due to publican issue (Bug 1174051)

Comment 5 Einav Cohen 2014-12-18 13:30:19 UTC
QE: there shouldn't be 404 responses anymore, however the PDFs may be 'stub' PDFs rather than 'production' PDFs (with actual content), as the production PDFs content may not be ready yet.

Comment 6 Greg Sheremeta 2014-12-18 14:19:18 UTC
PDFs are real / full content.

Comment 7 Pavel Novotny 2015-01-12 17:26:46 UTC
Verified in rhevm-doc-3.5.0-4.el6eng.noarch & rhevm-3.5.0-0.28.el6ev.noarch (vt13.6).

On the /ovirt-engine/ welcome page, all links to HTML and PDF documentation are valid now. Also content of the PDFs seem to be production-ready, no DRAFT watermarks or so.

* Administration Guide: /ovirt-engine/docs/manual/en_US/html/Administration_Guide/index.html
  [PDF] /ovirt-engine/docs/manual/en_US/pdf/Administration_Guide/Red_Hat_Enterprise_Virtualization-Administration_Guide.pdf
* Installation Guide: /ovirt-engine/docs/manual/en_US/html/Installation_Guide/index.html
  [PDF] /ovirt-engine/docs/manual/en_US/pdf/Installation_Guide/Red_Hat_Enterprise_Virtualization-Installation_Guide.pdf
* Technical Guide: /ovirt-engine/docs/manual/en_US/html/Technical_Guide/index.html
  [PDF] /ovirt-engine/docs/manual/en_US/pdf/Technical_Guide/Red_Hat_Enterprise_Virtualization-Technical_Guide.pdf
* User Guide: /ovirt-engine/docs/manual/en_US/html/User_Guide/index.html
  [PDF] /ovirt-engine/docs/manual/en_US/pdf/User_Guide/Red_Hat_Enterprise_Virtualization-User_Guide.pdf
* Manager Release Notes: /ovirt-engine/docs/manual/en_US/html/Manager_Release_Notes/index.html
  [PDF] /ovirt-engine/docs/manual/en_US/pdf/Manager_Release_Notes/Red_Hat_Enterprise_Virtualization-Manager_Release_Notes.pdf


Note You need to log in before you can comment on or make changes to this bug.