Bug 117208 - Category.getChildrenByURL(String path) : wrong parameter name __FILTERPARAMS__parentID
Summary: Category.getChildrenByURL(String path) : wrong parameter name __FILTERPARAMS_...
Status: CLOSED DUPLICATE of bug 112439
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-01 17:02 UTC by durnez
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description durnez 2004-03-01 17:02:33 UTC
Description of problem:

When i want to preview an item (attached to root category), i have an
exception.

com.arsdigita.persistence.PersistenceException:  (root cause:
com.redhat.persistence.engine.rdbms.RDBMSEngine$2: ORA-01008: not all
variables bound
)
        at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:137)
        at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:109)
        at
com.arsdigita.persistence.DataQueryImpl.next(DataQueryImpl.java:458)
        at
com.arsdigita.categorization.Category.getChildrenByURL(Category.java:2041)
        at
com.arsdigita.cms.dispatcher.CategoryItemResolverImpl.getItem(CategoryItemResolverImpl.java:191)


Version-Release number of selected component (if applicable):


How reproducible:
always (CMS 6.0.1)

Steps to Reproduce:
1. preview an item attached to root category.
  
Actual results:
exception (see above)

Expected results:
item preview

Additional info:

Solution is to replace (line 2037)
da.setParameter("__FILTERPARAMS__parentID", child.getID());

by 

da.setParameter("parentID", child.getID());

Comment 1 Richard Li 2004-03-01 17:10:21 UTC
This was fixed as part of bug 112439; see comment 13.
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=112439#c13)

*** This bug has been marked as a duplicate of 112439 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.