This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11721 - tetex-xdvi rpm doesn't require tetex
tetex-xdvi rpm doesn't require tetex
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-28 17:30 EDT by Sean Dilda
Modified: 2007-04-18 12:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.2-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-01 06:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SPEC file which cleans up inter-dependencies (50.18 KB, text/plain)
2004-06-28 12:08 EDT, Leonard den Ottolander
no flags Details
SPEC file which cleans up inter-dependencies (50.13 KB, text/plain)
2004-06-28 17:26 EDT, Leonard den Ottolander
no flags Details
Spec file fixes against tetex-2.0.2-16 (2.97 KB, patch)
2004-07-01 10:15 EDT, Leonard den Ottolander
no flags Details | Diff

  None (edit)
Description Sean Dilda 2000-05-28 17:30:45 EDT
The tetex-xdvi rpm shipped with RH6.2 will let you install it (without
errors) without having tetex installed.  However, in order to run, xdvi
needs some of the programs supplied by the tetex package.  The tetex-xdvi
rpm should be setup to require that the tetex rpm be installed first.
Comment 1 Gerald Teschl 2001-02-12 10:27:55 EST
Still broken in fisher. Please add tetex as an requirement for tetex-xdvi.

It will at least need the font generation binaries to work (MakeTeXPK, maybe 

others) which are part of tetex.



Best solution would be to move these tools to tetex-fonts, so somebody who is 

only interested in a viewer does not have to install tetex.



Comment 2 Tim Waugh 2001-09-30 17:22:39 EDT
I have had several abortive attempts at doing this, getting into a terrible 
mess each time. :-(
Comment 3 Leonard den Ottolander 2004-06-10 12:14:48 EDT
Why not just add a "Requires: tetex" on tetex-xdvi? How can that
result in a mess?
Comment 4 Tim Waugh 2004-06-24 13:18:07 EDT
The reason that the xdvi package was split out in the first place was
to avoid bringing in *all* of tetex just to use xdvi.

If the subpackage requires the main package anyway, there's no point
in *having* it as a sub-package and all of the files may as well be
owned by tetex in that case.
Comment 5 Leonard den Ottolander 2004-06-24 13:32:06 EDT
But if tetex-xdvi requires tetex the Requires should be there.

If that defeats the purpose of the split the split can just as well be
undone. Not much use for a separate package that isn't functional
without a dependency that one doesn't want to make explicit.

What is the problem with putting the necessary programs in tetex-fonts
an Requires-ing that?
Comment 6 Tim Waugh 2004-06-24 13:46:24 EDT
As I said in comment #2, it's hard.  It's the best thing to do, but
it's tricky to get it to work -- please feel free to have a go yourself.

In the mean time I'll put in a Requires: tetex so that it actually works.
Comment 7 Leonard den Ottolander 2004-06-24 14:35:02 EDT
What is it that makes this hard to accomplish? You haven't explained
that yet...
Comment 8 Leonard den Ottolander 2004-06-24 16:42:13 EDT
Note that I don't know anything of the internals of tetex (it's just
that I keep bumping into it when I am doing extensive builds from
source), but adding the following files to my setup makes xdvi work.

What's wrong with changing the spec file like this?:

--- tetex.spec.000	2003-08-08 15:33:48.000000000 +0200
+++ tetex.spec	2004-06-24 22:30:16.000000000 +0200
@@ -622,6 +622,17 @@
 	grep -v "/usr/share/texmf/fonts/tfm/jp" | \
 	grep -v "/usr/share/texmf/fonts/vf/ptex" | \
 	grep -v "/usr/share/texmf/fonts/source" > filelist.fonts
+echo "%{_bindir}/gsftopk"			>> filelist.fonts
+echo "%{_bindir}/ksewhich"			>> filelist.fonts
+echo "%{_bindir}/mktexpk"			>> filelist.fonts
+echo "%{_datadir}/texmf/web2c/mktex.cnf"	>> filelist.fonts
+echo "%{_datadir}/texmf/web2c/mktex.opt"	>> filelist.fonts
+echo "%{_datadir}/texmf/web2c/mktexnam"		>> filelist.fonts
+echo "%{_datadir}/texmf/web2c/mktexnam.opt"	>> filelist.fonts
+echo "%{_datadir}/texmf/web2c/mktexupd"		>> filelist.fonts
+echo "%{_mandir}/man1/gsftopk.1.gz"		>> filelist.fonts
+echo "%{_mandir}/man1/ksewhich.1.gz"		>> filelist.fonts
+echo "%{_mandir}/man1/mktexpk.1.gz"		>> filelist.fonts
 
 grep -v "/doc/" filelist.full | grep afm 	> filelist.afm
 

Any files missing?
Comment 9 Leonard den Ottolander 2004-06-24 19:41:05 EDT
That of course should have been

+echo "%{_bindir}/kpsewhich"			>> filelist.fonts
+echo "%{_mandir}/man1/kpsewhich.1.gz"		>> filelist.fonts

Not sure if to also move
/usr/lib/kpathsea.a (and what about /usr/include? tetex-devel?)
/usr/bin/kpse* + man pages
/usr/bin/mktex* + man pages

Maybe these files should be put in a separate tetex-fontutils package
which is required both by tetex and tetex-xdvi/-fonts instead?
Comment 10 Tim Waugh 2004-06-28 06:07:12 EDT
Leonard: the answer to "what's wrong with..." is: I don't know.  I
just remember that when I tried to move files around in 2001 it ended
up breaking things.

I understand that you're working on a tetex-common package; let me
know what you end up with, because it would be great to fix this.  Thanks.
Comment 11 Leonard den Ottolander 2004-06-28 12:08:39 EDT
Created attachment 101472 [details]
SPEC file which cleans up inter-dependencies

Move some files to tetex-fonts, which is now the central package.

See the fedora-devel list ("Tetex inter-dependencies: proposed changes") for
details.
Comment 12 Leonard den Ottolander 2004-06-28 17:26:27 EDT
Created attachment 101483 [details]
SPEC file which cleans up inter-dependencies

Small fixes to previous SPEC file.
Relevant man pages to tetex-dvips.
Comment 13 Tim Waugh 2004-07-01 06:21:38 EDT
Great, thanks!  I've built this into 2.0.2-16, which should appear in
rawhide tomorrow.  The spec file is here in the meantime:

ftp://people.redhat.com/twaugh/tmp/tetex/tetex.spec

It would be useful if you could check through the changes, as I had to
pick through a diff from 2.0.2-8 (which I think is what you started
from).  In future diffs will be more useful than complete files.
Comment 14 Leonard den Ottolander 2004-07-01 09:09:27 EDT
Diffs will be fine next time. Thought with the version it would be
obvious enough from which file I started :) .

Please check afm's dependency. I am not entirely sure about that.
About the other changes I am quite confident.
Comment 15 Leonard den Ottolander 2004-07-01 10:15:49 EDT
Created attachment 101563 [details]
Spec file fixes against tetex-2.0.2-16

Fix a few omissions. Drop tetex-afm Requires as it can function independently.
Comment 16 Tim Waugh 2004-07-01 10:55:35 EDT
Thanks!  Built as tetex-2.0.2-17.

Note You need to log in before you can comment on or make changes to this bug.