Bug 117217 - rpm should automatically recognize new macro files dropped into /etc/rpm
rpm should automatically recognize new macro files dropped into /etc/rpm
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 13:30 EST by Thomas Fitzsimmons
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-23 10:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2004-03-01 13:30:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The jpackage-utils package defines various rpm macros for use by other
jpackage spec files.  The macros are installed in a file,
/etc/rpm/macros.jpackage.

jpackage-utils used to define %postun and %triggerin sections that
modified /usr/lib/rpm/rpmrc to register and unregister macros.jpackage
with rpm.  This is unacceptable for various reasons.

The problem would be solved if rpm automatically recognized and loaded
all macro files that appeared in /etc/rpm/

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The problem was discovered when attempting to build jpackage-utils
into beehive.


Additional info:
Comment 1 Jeff Johnson 2004-03-01 20:51:02 EST
A change to use a glob instead of explicit files was checked
in. Should be in rpm-4.3-0.17.

Note that dropping in a configuration change to rpm
that is loaded by all builds has deep and profound
consequences. You *really* should think carefully
before attempting macros.jpackage,as most rpm
users are not java programmers, and jpackage-utils
could probably be built in other ways.

Off to redhat-rpm-config for macros.jpackage content vetting.
Comment 2 James Olin Oden 2004-03-02 19:27:32 EST
Just as an alternate approach.  Where I work what we do is we 
drop such macro files in like /etc/rpm.d, and then we have an RC 
script that combines those into /etc/rpm/macros.  My point is though 
this is usefull functionality (i.e. allowing for globbing of a 
directory, you can get there by other means fairly easily.

Cheers...james
Comment 3 Dmitry V. Levin 2004-03-07 17:19:36 EST
JFYI, in ALT Linux we use this globbing feature since Aug 28 2002. 
Our macrofiles list contains "/etc/rpm/macros.d/*" entry, and we have simple 
policy how this submacrofiles should be written. 
Comment 4 Elliot Lee 2004-04-23 10:18:16 EDT
redhat-rpm-config edited to use this feature. Thanks for adding it Jeff!

Note You need to log in before you can comment on or make changes to this bug.