Bug 1172191 - engine-backup does not sanitize the environment
Summary: engine-backup does not sanitize the environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yedidyah Bar David
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-09 14:54 UTC by Yedidyah Bar David
Modified: 2019-04-28 09:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:52:29 UTC
oVirt Team: Integration
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 36373 master MERGED packaging: engine-backup: clean env at start Never

Description Yedidyah Bar David 2014-12-09 14:54:33 UTC
Description of problem:

$subject. E.g. setting PGPASSWORD to a wrong value makes pg_dump try it even though we create a temporary pgpass file and set PGPASSFILE.

Version-Release number of selected component (if applicable):

Since 3.3 I think

How reproducible:

Always

Steps to Reproduce:
1. export PGPASSWORD=wrongpass
2. engine-backup
3.

Actual results:

Fails

Expected results:

Succeeds

Additional info:

Comment 1 Gonza 2015-10-07 12:25:12 UTC
Verified with:
rhevm-3.6.0-0.12.master.el6.noarch

After exporting PGPASSWORD with a wrong pass the engine-backup is completed successfully.

Comment 4 errata-xmlrpc 2016-03-09 20:52:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.