Bug 1172290 - the r.js script is not executable and not in the default PATH
Summary: the r.js script is not executable and not in the default PATH
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs-requirejs
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jamie Nguyen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-09 19:15 UTC by Dridi Boukelmoune
Modified: 2015-02-05 19:02 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-01-17 05:36:33 UTC


Attachments (Terms of Use)

Description Dridi Boukelmoune 2014-12-09 19:15:06 UTC
Description of problem:

Ideally I should be able to run "r.js" or at least "/usr/lib/node_modules/requirejs/bin/r.js" from the command line. It is meant to be run as such:

$ sed 1q /usr/lib/node_modules/requirejs/bin/r.js
#!/usr/bin/env node

Version-Release number of selected component (if applicable):

Name        : nodejs-requirejs
Version     : 2.1.11
Release     : 1.fc20

How reproducible:

Always.

Steps to Reproduce:
1. yum install nodejs-requirejs

Actual results:

$ ls -l /usr/lib/node_modules/requirejs/bin/r.js
-rw-r--r--. 1 root root 1030279 Feb 17  2014 /usr/lib/node_modules/requirejs/bin/r.js

Expected results:

$ ls -l /usr/lib/node_modules/requirejs/bin/r.js
-rwxr-xr-x. 1 root root 1030279 Feb 17  2014 /usr/lib/node_modules/requirejs/bin/r.js

Additional info:

A /usr/bin/r.js symlink with "chmod +x /usr/lib/node_modules/requirejs/bin/r.js" works fine on my machine.

Comment 1 Dridi Boukelmoune 2014-12-10 17:16:55 UTC
Additional additional info:

As I'm new to RequireJS, I've just discovered that one expects to have r.js in its PATH after installing it with npm.

http://tech.pro/blog/1639/using-rjs-to-optimize-your-requirejs-project

Comment 2 Fedora Update System 2015-01-02 11:33:35 UTC
nodejs-requirejs-2.1.11-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nodejs-requirejs-2.1.11-3.fc21

Comment 3 Fedora Update System 2015-01-02 11:34:00 UTC
nodejs-requirejs-2.1.11-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nodejs-requirejs-2.1.11-3.fc20

Comment 4 Fedora Update System 2015-01-02 11:35:49 UTC
nodejs-requirejs-2.1.11-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nodejs-requirejs-2.1.11-3.fc19

Comment 5 Fedora Update System 2015-01-02 11:37:17 UTC
nodejs-requirejs-2.1.11-3.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/nodejs-requirejs-2.1.11-3.el7

Comment 6 Fedora Update System 2015-01-02 11:37:50 UTC
nodejs-requirejs-2.1.11-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-requirejs-2.1.11-3.el6

Comment 7 Jamie Nguyen 2015-01-02 11:40:20 UTC
Sorry about the oversight and delay in reply. Thanks for reporting!

The above updates should fix the issue.

Comment 8 Fedora Update System 2015-01-03 00:13:30 UTC
Package nodejs-requirejs-2.1.11-3.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nodejs-requirejs-2.1.11-3.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0010/nodejs-requirejs-2.1.11-3.el7
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-01-17 05:36:33 UTC
nodejs-requirejs-2.1.11-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-01-17 05:44:36 UTC
nodejs-requirejs-2.1.11-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-02-05 19:01:21 UTC
nodejs-requirejs-2.1.11-3.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-02-05 19:02:02 UTC
nodejs-requirejs-2.1.11-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.