Bug 1172317 - [evince] is screwed up by a Postscript file which is displayed correctly by ghostscript
Summary: [evince] is screwed up by a Postscript file which is displayed correctly by g...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libspectre
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1248847 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-09 20:10 UTC by Joachim Frieben
Modified: 2015-08-12 07:00 UTC (History)
3 users (show)

Fixed In Version: libspectre-0.2.7-6.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 06:56:54 UTC
Type: Bug


Attachments (Terms of Use)
Sample PS file (52.30 KB, image/x-eps)
2014-12-09 20:11 UTC, Joachim Frieben
no flags Details
Sample PDF file obtained by conversion with ps2pdf (42.84 KB, application/pdf)
2014-12-09 20:12 UTC, Joachim Frieben
no flags Details
Screenshot of evince after opening the sample PS file (199.30 KB, image/png)
2014-12-09 20:13 UTC, Joachim Frieben
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 76450 0 None None None Never

Description Joachim Frieben 2014-12-09 20:10:24 UTC
Description of problem:
After opening the attached PS file, the document pane of evince stays empty and after trying to access some widgets of the viewer the window decorations start to show weird colour changes and other artifacts. The following sequence is spawned to the console repeatedly when evince was launched from it:

(evince:4007): Gtk-WARNING **: drawing failure for widget `EvView': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `GtkScrolledWindow': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `GtkOverlay': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `GtkBox': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `GtkPaned': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `GtkBox': invalid matrix (not invertible)
(evince:4007): Gtk-WARNING **: drawing failure for widget `EvWindow': invalid matrix (not invertible)

Version-Release number of selected component (if applicable):
evince-3.14.1-3.fc21

How reproducible:
Always.

Steps to Reproduce:
1. Open attached PS file "bphi.ps".

Actual results:
Document is not displayed and after a moment rendering artifacts affect the window borders.

Expected results:
Document is displayed as expected.

Additional info:
- ghostscript displays the document as expected
- after converting the PS file to PDF by means of ps2pdf, the resulting PDF file is displayed instantaneously and correctly

Comment 1 Joachim Frieben 2014-12-09 20:11:25 UTC
Created attachment 966446 [details]
Sample PS file

Comment 2 Joachim Frieben 2014-12-09 20:12:11 UTC
Created attachment 966448 [details]
Sample PDF file obtained by conversion with ps2pdf

Comment 3 Joachim Frieben 2014-12-09 20:13:39 UTC
Created attachment 966451 [details]
Screenshot of evince after opening the sample PS file

Comment 4 Marek Kašík 2014-12-10 09:34:16 UTC
This is the same problem as in https://bugs.freedesktop.org/show_bug.cgi?id=76450. The patch there fixes the problem for me but it introduces some other problems. I'm working on improving it and I will push it to Fedora's libspectre once it is ready.

Comment 5 Joachim Frieben 2015-02-07 14:30:48 UTC
For current Fedora 21, the colour artifacts observed for the window decorations are gone. Indeed, even the PS figure is shown correctly after rotating it by 90 degrees either to the left or to the right.

Comment 6 Marek Kašík 2015-07-31 13:14:19 UTC
*** Bug 1248847 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-07-31 13:19:45 UTC
libspectre-0.2.7-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libspectre-0.2.7-6.fc21

Comment 8 Fedora Update System 2015-07-31 13:21:01 UTC
libspectre-0.2.7-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libspectre-0.2.7-6.fc22

Comment 9 Fedora Update System 2015-07-31 13:22:08 UTC
libspectre-0.2.7-7.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/libspectre-0.2.7-7.fc23

Comment 10 Marek Kašík 2015-07-31 13:26:10 UTC
I went ahead and pushed the patch to F21, F22, F23 and master.

Comment 11 Fedora Update System 2015-08-01 02:28:01 UTC
Package libspectre-0.2.7-6.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libspectre-0.2.7-6.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12571/libspectre-0.2.7-6.fc21
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2015-08-10 10:01:44 UTC
libspectre-0.2.7-7.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-08-12 06:56:54 UTC
libspectre-0.2.7-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-08-12 07:00:02 UTC
libspectre-0.2.7-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.