Bug 117236 - (DRM RADEON)kernel panic (2.6.1-1.65smp), with trace
(DRM RADEON)kernel panic (2.6.1-1.65smp), with trace
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 16:37 EST by Dams
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 01:40:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output 2.6.1-1.65. (15.45 KB, text/plain)
2004-03-01 16:38 EST, Dams
no flags Details
dmesg output 2.6.3-1.116 (14.89 KB, text/plain)
2004-03-02 11:45 EST, Dams
no flags Details

  None (edit)
Description Dams 2004-03-01 16:37:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
Here is the trace : 

irq 169: nobody cared!
Call Trace:
 [<c010e124>] __report_bad_irq+0x24/0x90
 [<c010e211>] note_interrupt+0x61/0x90
 [<c010e5c2>] do_IRQ+0x182/0x210
 [<c011e0ac>] smp_apic_timer_interrupt+0xdc/0x140
 [<c010c624>] common_interrupt+0x18/0x20
 [<c0109030>] default_idle+0x0/0x40
 [<c0109059>] default_idle+0x29/0x40
 [<c01090eb>] cpu_idle+0x3b/0x50
 [<c012b117>] printk+0x177/0x250
 
handlers:
[<e0c61d90>] (radeon_dma_service+0x0/0xd0 [radeon])
Disabling IRQ #169

(will attach the full dmesg output)

[anvil@gruyere ~]# cat /proc/interrupts|grep 169
169:    1811251     864908   IO-APIC-level  radeon@PCI:1:5:0

Irq 169 is my video card. I'm not sure disabling its IRQ is a good
thing for me :)

[anvil@gruyere ~]# sudo lspci -vvvv|less
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD
[Radeon 7200] (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc Radeon 7000/Radeon
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR- FastB2B-        Status: Cap+ 66Mhz+ UDF-
FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min), cache line size 08
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at f4000000 (32-bit, prefetchable) [size=64M]
        Region 1: I/O ports at d800 [size=256]
        Region 2: Memory at f1800000 (32-bit, non-prefetchable)
[size=512K]
        Expansion ROM at f3fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=47 SBA+ 64bit- FW- Rate=x1,x2,x4
                Command: RQ=15 SBA+ AGP+ 64bit- FW- Rate=x4
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

It happens when i have tvtime (srpm from rawhide) and foobillard (from
fedora.us) at the same time. It happened with 2.4 kernels too, but i
wasnt able to save the trace because system with hardlocked.

Version-Release number of selected component (if applicable):
2.6.1-1.65smp

How reproducible:
Always

Steps to Reproduce:
1. tvtime & (using Xv rendering)
2. foobillard (opengl stuff) in window mode.
3. Play pool, move the window. dont worry, it'll come.


Additional info:

System is dual athlon with Radeon 7200 (described above). Tv card is a
bt878 based philips card. System is up-to-date fc1 with kernel package
downloaded from rawhide.
Comment 1 Dams 2004-03-01 16:38:21 EST
Created attachment 98176 [details]
dmesg output 2.6.1-1.65.
Comment 2 Dams 2004-03-02 11:40:28 EST
I tried others kernel-smp packages.

kernel-smp(0:2.6.3-1.116).i686 reports : 

[drm:radeon_lock_take] *ERROR* 4 holds heavyweight lock
irq 169: nobody cared!
Call Trace:
 [<c010d617>] __report_bad_irq+0x2b/0x67
 [<c010d6af>] note_interrupt+0x43/0x66
 [<c010d9a1>] do_IRQ+0x13b/0x1b8
 [<c011b82f>] smp_apic_timer_interrupt+0x124/0x129
 [<c010c04c>] common_interrupt+0x18/0x20
 
handlers:
[<e08deb14>] (radeon_dma_service+0x0/0xa1 [radeon])
Disabling IRQ #169

(will attach full dmesg output)

Symptoms with kernel-smp(0:2.6.3-1.118).i686 :
0. tvtime & (optional, but makes the system freeze easier)
1. foobillard &
2. try to move foobillard window

Actual results : window manager seems locked (no window can be moved,
keyboard doesnt respond, caps lock doesnt work anymore). And this
message appear in kernel output : 
[drm:radeon_lock_take] *ERROR* 4 holds heavyweight lock

If i remotely kill (have to kill -9, sigterm isnt enough) foobillard,
system seems fine. If, instead of killing foobillard, you kill [-9] X,
screen turns off. And remote shell doesnt respond anymore. System
still pings though. I've not been able to catch a panic trace. with
2.6.3-1.118smp.
Comment 3 Dams 2004-03-02 11:45:01 EST
Created attachment 98196 [details]
dmesg output 2.6.3-1.116
Comment 4 Dave Jones 2004-11-27 15:54:58 EST
any improvement with teh 2.6.9 based update kernels ?

Note You need to log in before you can comment on or make changes to this bug.