Bug 117252 - LILO did not update kernel
Summary: LILO did not update kernel
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: lilo   
(Show other bugs)
Version: 1
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-02 04:37 UTC by Jim Harvey
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-02 10:17:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Harvey 2004-03-02 04:37:45 UTC
Description of problem:
LILO update failed

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Upgrade from RH9 to Core 1.  Comleted successfully but many errors
during subsequent bootup and lots of things did not work - no ethernet
card, no usb etc.  Noticed that in dmesg, the system was booting into
the old RH9 kernel not the Core 1 version.  Apparently LILO had not
successfully run.  There is a line in my lilo.conf
message=/boot/message and that file was missing.  Lilo wouldn't
complete because of this.  I created the /boot/message file, then lilo
ran ok and the system not boots normally into the 2.4.22-1.2115.nptl
kernel.

Expected results:
Need better lilo error handling.

Additional info:
This took a lot of time to figure out.

Comment 1 Marius Andreiana 2005-11-02 10:17:27 UTC
Lilo is deprecated, please use GRUB.


Note You need to log in before you can comment on or make changes to this bug.