Bug 1172545 - hosted engine deploy on vlan Cannot acquire bridge address
Summary: hosted engine deploy on vlan Cannot acquire bridge address
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard: integration
Depends On: 1172287
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-12-10 10:53 UTC by Simone Tiraboschi
Modified: 2015-02-11 20:41 UTC (History)
14 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.1-8.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, a bug in the regular expression prevented correct fetching of the IP address for VLAN interfaces, which in turn prevented the deployment of the hosted engine. Now, the regular expression used to fetch the IP address for VLAN interfaces has been corrected and the hosted engine can be deployed using VLAN.
Clone Of: 1172287
Environment:
Last Closed: 2015-02-11 20:41:50 UTC
oVirt Team: ---


Attachments (Terms of Use)
two hosts and HE on top of them screen-shot. (83.06 KB, image/png)
2015-01-15 18:04 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 36047 None None None Never
oVirt gerrit 36076 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: matching also virtual interface names Never

Description Simone Tiraboschi 2014-12-10 10:53:33 UTC
+++ This bug was initially created as a clone of Bug #1172287 +++

Description of problem:
I've got a hosted engine up and running on a freshly installed 
3.5 host (CentOS 6.6), and I'm tyying to add a second host. The 
install fails trying to configure the ovirtmgmt bridge:

[ INFO  ] Updating hosted-engine configuration
[ INFO  ] Stage: Transaction commit
[ INFO  ] Stage: Closing up
[ ERROR ] Failed to execute stage 'Closing up': Cannot acquire bridge address

Version-Release number of selected component (if applicable):


How reproducible:
every time


Steps to Reproduce:
1. set up hosted-engine on 1st host using vlan
2. try to deploy on second host with vlan suing name of the form ethN.V
3.

Actual results:
setup cannot aquire bridge address

Expected results:
setup succeeds

Additional info:
See ovirt-users message thread started around On Wed, 5 Nov 2014 19:57:07 -0500 with subject "3.5 hosted engine: 2nd host Cannot acquire bridge address"

complete logs from the second host at 
  http://futz.org/users/tmp/ovirt7/

On Tue, 09 Dec 2014 10:32:39 +0100 Sandro wrote:
Looking at setup logs, you have: OVEHOSTED_NETWORK/bridgeIf=str:'eth1.79'

and when it try to get the ip address for the interface:

2014-11-05 19:35:03 DEBUG otopi.plugins.ovirt_hosted_engine_setup.engine.add_host plugin.execute:861 execute-output: ('/sbin/ip', 'addr', 'show',
'eth1.79') stdout:
4: eth1.79@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 00:26:9e:0b:31:e5 brd ff:ff:ff:ff:ff:ff
    inet 10.69.79.32/24 brd 10.69.79.255 scope global eth1.79
    inet6 fe80::226:9eff:fe0b:31e5/64 scope link
       valid_lft forever preferred_lft forever

2014-11-05 19:35:03 DEBUG otopi.plugins.ovirt_hosted_engine_setup.engine.add_host plugin.execute:866 execute-output: ('/sbin/ip', 'addr', 'show',
'eth1.79') stderr:


2014-11-05 19:35:03 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/engine/add_host.py", line 485, in _closeup
    address=self._getIPAddress(),
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/engine/add_host.py", line 199, in _getIPAddress
    raise RuntimeError(_('Cannot acquire bridge address'))
RuntimeError: Cannot acquire bridge address


which seems to fail matching REGEXP:

    _ADDRESS_RE = re.compile(
        flags=re.VERBOSE,
        pattern=r"""
            \s+
            inet
            \s
            (?P<address>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})
            .+
            \s+
            (?P<interface>\w+)
            $
    """
    )

I guess the match is failing due to the '.' in 'eth1.79'

Comment 2 Nikolai Sednev 2015-01-15 18:03:27 UTC
Works for me on these components:
Engine:
rhevm-3.5.0-0.29.el6ev.noarch
rhevm-guest-agent-common-1.0.10-2.el6ev.noarch
Linux version 2.6.32-504.3.3.el6.x86_64 (mockbuild@x86-028.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-9) (GCC) ) #1 SMP Fri Dec 12 16:05:43 EST 2014

Hosts:
libvirt-client-1.1.1-29.el7_0.4.x86_64
vdsm-4.16.8.1-5.el7ev.x86_64
ovirt-hosted-engine-setup-1.2.1-8.el7ev.noarch
qemu-kvm-rhev-1.5.3-60.el7_0.11.x86_64
mom-0.4.1-4.el7ev.noarch
sanlock-3.1.0-2.el7.x86_64
Linux version 3.10.0-123.19.1.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.2 20140120 (Red Hat 4.8.2-16) (GCC) ) #1 SMP Mon Dec 15 14:04:04 EST 2014


I've installed RHEL7.0 freshly on 2 hosts, then created 802.1Q interface on both hosts, checked that they're reaching each other via tagged interface, ran hosted-engine deployment on first host, installed HE on VM, ran hosted-engine deployment on second host and using answer file from first host completed the deployment.

Please also see the attachment of a screen-shot of two hosts and hosted engine running on top of them.

Comment 3 Nikolai Sednev 2015-01-15 18:04:17 UTC
Created attachment 980577 [details]
two hosts and HE on top of them screen-shot.

Comment 5 errata-xmlrpc 2015-02-11 20:41:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.