Bug 1172612 - Nova launch instance from snapshot ignores --min-disk
Summary: Nova launch instance from snapshot ignores --min-disk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
unspecified
Target Milestone: ga
: 10.0 (Newton)
Assignee: Matthias Runge
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-10 13:13 UTC by Tzach Shefi
Modified: 2019-09-09 13:33 UTC (History)
15 users (show)

Fixed In Version: python-django-horizon-10.0.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:26:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
Launchpad 1401101 None None None Never

Description Tzach Shefi 2014-12-10 13:13:31 UTC
Description of problem: Nova launch instance from Horizon, if glance image has --min-disk set insufficient flavors are filtered out. When launching from a snapshot with --min-disk set, flavors aren't filtered out, they all show up even flavors with insufficient disk size. 


Version-Release number of selected component (if applicable):
rhel7 
python-nova-2014.1.3-9.el7ost.noarch
openstack-nova-compute-2014.1.3-9.el7ost.noarch
openstack-nova-common-2014.1.3-9.el7ost.noarch
python-novaclient-2.17.0-2.el7ost.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Upload an image to glance, set --min-disk to say 20G
2. Try to launch an instance from within horizon from that image, notice tiny flavor is grayed out. 
3. From the booted instance above create a snapshot
4. Edit that snapshot   #glance image-update snapID --min-disk 20
5. From horizon boot an instance from the snapshot, notice you can select any flavor including tiny which should have been grayed out as in the case of image on step 2.


Actual results:
Tiny flavor isn't filtered from Horizon launch instance page.

Expected results:
As in the case of image if --min-disk is set any flavor with insufficient disk space should be grayed out.

If this happens to --min-disk it might also happen with --min-ram.

Comment 1 Stephen Gordon 2014-12-29 16:11:00 UTC
Moving to python-django-horizon as I do not believe there is a Nova bug here.

Comment 2 Matthias Runge 2015-01-08 13:36:06 UTC
when using snapshots (volume or image), flavors are currently not filtered.

Upstream refactored the whole section there, backporting might be trickier.

However, when trying to launch such an instance providing a flavor too small, launch fails with an error message: e.g.:
Flavor's memory is too small for requested image.

Comment 3 Matthias Runge 2015-02-11 11:23:12 UTC
The launch instance dialogue will see a major change in kilo release. I would expect this to be fixed then.

Unfortunately, for technical reasons, there will be no backport.

Comment 4 Matthias Runge 2015-06-24 08:57:30 UTC
moving to 8, it will probably move to new launch ui

Comment 5 Matthias Runge 2015-12-01 07:20:50 UTC
Still unfixed

Comment 6 Itxaka 2016-06-28 13:25:50 UTC
Fixed upstream, backport to mitaka in progress https://review.openstack.org/#/c/335026/

Comment 10 errata-xmlrpc 2016-12-14 15:26:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.