Bug 1172669 - Update hal-info remapping rules for Toshiba laptops
Summary: Update hal-info remapping rules for Toshiba laptops
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hal-info
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Benjamin Tissoires
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1146711
TreeView+ depends on / blocked
 
Reported: 2014-12-10 14:20 UTC by Benjamin Tissoires
Modified: 2015-07-22 05:36 UTC (History)
4 users (show)

Fixed In Version: hal-info-20090716-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 05:36:03 UTC


Attachments (Terms of Use)
30-keymap-module-toshiba-acpi.fdi (465 bytes, text/plain)
2014-12-18 15:41 UTC, Benjamin Tissoires
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1268 normal SHIPPED_LIVE hal-info bug fix update 2015-07-20 17:49:32 UTC

Description Benjamin Tissoires 2014-12-10 14:20:07 UTC
Description of problem:

To support the various Fn-keys found on the latest Toshiba laptops, we need to introduce a remapping from the provided kernel keycode to a keycode compatible with X.

For instance KEY_TOUCHPAD_TOGGLE has to be remapped to F21 for X to be able to deliver Xf86TouchpadToggle.


Version-Release number of selected component (if applicable):
6.6

How reproducible:
Always

Steps to Reproduce:
1. run xev
2. hit the corresponding touchpad toggle key 
3. see the xev output

Actual results:

xev does not show Xf86TouchpadToggle

Expected results:

xev should show Xf86TouchpadToggle

Additional info:

Comment 1 Benjamin Tissoires 2014-12-18 15:41:59 UTC
Created attachment 970629 [details]
30-keymap-module-toshiba-acpi.fdi

Attached is the policy key mapping required for the Toshiba laptops.
Only Touchpad toggle needs to be remapped from what I can see on the keyboard.

Comment 7 errata-xmlrpc 2015-07-22 05:36:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1268.html


Note You need to log in before you can comment on or make changes to this bug.