Bug 1172671 - Error messages appear in .instack/install-undercloud.log
Summary: Error messages appear in .instack/install-undercloud.log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-10 14:20 UTC by Udi
Modified: 2015-08-05 13:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:49:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2014-12-10 14:20:48 UTC
Description of problem:
After running instack-install-undercloud as per the instructions in https://openstack.redhat.com/Deploying_an_RDO_Undercloud_with_Instack you can see this traceback near the end of the log:


ERROR:tuskarclient.shell:Exiting due to an error:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 226, in main
    TuskarShell(sys.argv[1:]).run()
  File "/usr/lib/python2.7/site-packages/tuskarclient/shell.py", line 73, in run
    args.func(tuskar_client, args)
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans_shell.py", line 24, in do_plan_list
    plans = tuskar.plans.list()
  File "/usr/lib/python2.7/site-packages/tuskarclient/v2/plans.py", line 87, in list
    return self._list(self._path())
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/base.py", line 84, in _list
    resp, body = self.api.json_request('GET', url)
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/http.py", line 201, in json_request
    resp, body_iter = self._http_request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/tuskarclient/common/http.py", line 159, in _http_request
    'endpoint': self.endpoint, 'e': e})
CommunicationError: Error communicating with http://192.0.2.1:8585/ [Errno 111] Connection refused


Version-Release number of selected component (if applicable):
instack-undercloud-1.0.25-1.fc22.noarch


How reproducible:
100%


Steps to Reproduce:
1. Follow the instructions in https://openstack.redhat.com/Deploying_RDO_on_a_Virtual_Machine_Environment_using_Instack and https://openstack.redhat.com/Deploying_an_RDO_Undercloud_with_Instack
2. Look for errors, warnings and other deprecation messages in .instack/install-undercloud.log


Actual results:
Numerous errors, warnings and deprecation messages. They indicate that there might be a problem somewhere, although I don't know exactly which use cases are be affected (if any).


Expected results:
The log should be clean of errors if they are not real errors.

Comment 6 errata-xmlrpc 2015-08-05 13:49:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.